Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

KSP 1.1.3: Missing method exception #161

Closed
ihsoft opened this issue Jun 22, 2016 · 4 comments

Comments

@ihsoft
Copy link
Owner

commented Jun 22, 2016

When scene object is attempted to be moved via KIS the following error is thrown:

160621T214418.065 [EXCEPTION] [KIS.KISAddonPickup.OnPointerAction] MissingMethodException: Method not found: 'Vessel.SetPosition'.
   at KIS.KISAddonPickup.OnPointerAction (PointerTarget pointerTarget, Vector3 pos, Quaternion rot, .Part tgtPart, System.String srcAttachNodeID, .AttachNode tgtAttachNode)
   at KIS.KISAddonPointer.UpdatePointer ()
   at KIS.KISAddonPointer.Update ()

WORKAROUND. Drag the part from scene into inventory. Then drag it out of inventory to the new location.

@ihsoft ihsoft added the bug label Jun 22, 2016

@ihsoft ihsoft added this to the 1.2.12 milestone Jun 22, 2016

@ihsoft

This comment has been minimized.

Copy link
Owner Author

commented Jun 22, 2016

No actual code change needed. Only rebuild with the latest KSP binaries.

@reedrs

This comment has been minimized.

Copy link

commented Jun 28, 2016

  • KSP 1.1.2
  • KIS 1.2.12 from CKAN
  • Arch Linux x86_64
[LOG 23:00:29.680] Set pointer mode to: Drop
[EXC 23:00:30.132] MissingMethodException: Method not found: 'Vessel.SetPosition'.
        KIS.KISAddonPickup.OnPointerAction (PointerTarget pointerTarget, Vector3 pos, Quaternion rot, .Part tgtPart, System.String srcAttachNodeID, .AttachNode tgtAttachNode)
        KIS.KISAddonPointer.UpdatePointer ()
        KIS.KISAddonPointer.Update ()
[LOG 23:00:30.612] Launcher here(in write): False
[LOG 23:00:30.810] Cancel key pressed, stop eva attach mode
[LOG 23:00:30.810] StopPointer()

I'm getting this error when trying to place/move parts with 1.1.2. It does not occur with 1.1.3.

@ihsoft

This comment has been minimized.

Copy link
Owner Author

commented Jun 28, 2016

KIS 1.2.12 is incompatible with 1.1.2. It will only work with 1.1.3 and higher.

And thanks for the bug, I'll add minimum version requirement into CKAN file.

@reedrs

This comment has been minimized.

Copy link

commented Jun 28, 2016

Ah ok, glad to help.

In that case, where can I download the last 1.1.2-compatible release?

Edit: here: http://kerbal.curseforge.com/projects/kerbal-inventory-system-kis/files

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.