Permalink
Browse files

Use cocoapods 1.6.0, remove cocoapods workaround

  • Loading branch information...
alejx committed Feb 8, 2019
1 parent b3addc1 commit e780f007ae92661f6f8386c908469a6c25fc2a98
Showing with 2 additions and 6 deletions.
  1. +1 −3 .travis.yml
  2. +1 −1 Podfile.lock
  3. +0 −2 README.md
@@ -2,9 +2,7 @@ language: swift
osx_image: xcode10.1

before_install:
# Workaround for https://github.com/CocoaPods/CocoaPods/issues/7708.
# Remove when CocoaPods 1.6.0 is released.
- gem install cocoapods --pre
- gem install cocoapods

# Build the main app, which happens to depend on the other two targets.
script: xcodebuild -workspace iina.xcworkspace -scheme iina
@@ -47,4 +47,4 @@ SPEC CHECKSUMS:

PODFILE CHECKSUM: c149e2f5a370325310fa22313fe8c514d0967750

COCOAPODS: 1.6.0.beta.2
COCOAPODS: 1.6.0
@@ -39,8 +39,6 @@ IINA ships with pre-compiled dynamic libraries for convenience reasons. If you a

1. IINA uses [CocoaPods](https://cocoapods.org) for managing the installation of third-party libraries. If you don't already have it installed, here's how you can do so:

*Note: The current stable version of CocoaPods [has an unfortunate bug](https://github.com/CocoaPods/CocoaPods/issues/7708) that prevents IINA from building, which has luckily been fixed in their master branch and set to roll out in version 1.6. To get access to this version, please install CocoaPods with `sudo gem install cocoapods --pre` and ignore the installation instructions below*.

#### Using RubyGems
```console
$ sudo gem install cocoapods

0 comments on commit e780f00

Please sign in to comment.