memcache java library is not compiled for 1.5 compatibility #3

Closed
bjones opened this Issue Jun 16, 2010 · 4 comments

Comments

Projects
None yet
2 participants
@bjones

bjones commented Jun 16, 2010

Try using with java 1.5, you'll get a class version error. Solution is to download the library source and compile it yourself. Be aware it requires 1.5 or higher. Copy the .jar over to where it belongs and things should work. I'd recommend at least a warning that the compiled version included with this client only works with version X and higher.

@fredjean

This comment has been minimized.

Show comment Hide comment
@fredjean

fredjean Jun 30, 2010

Collaborator

Java 5 reached Sun's End of Service Life on October 28th, 2009 1. I strongly recommend upgrading to Java 6.

Collaborator

fredjean commented Jun 30, 2010

Java 5 reached Sun's End of Service Life on October 28th, 2009 1. I strongly recommend upgrading to Java 6.

@bjones

This comment has been minimized.

Show comment Hide comment
@bjones

bjones Jul 7, 2010

Good idea, just thought it worth adding to the readme for the gem.

bjones commented Jul 7, 2010

Good idea, just thought it worth adding to the readme for the gem.

@fredjean

This comment has been minimized.

Show comment Hide comment
@fredjean

fredjean Jul 7, 2010

Collaborator

Fair enough...

Collaborator

fredjean commented Jul 7, 2010

Fair enough...

@fredjean

This comment has been minimized.

Show comment Hide comment
@fredjean

fredjean Sep 6, 2010

Collaborator

I have updated my repo's copy of the read me to address this concern.

Collaborator

fredjean commented Sep 6, 2010

I have updated my repo's copy of the read me to address this concern.

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment