Skip to content
Newer
Older
100644 54 lines (46 sloc) 1.36 KB
f6bf167 @technoweenie Initial commit to faraday.
technoweenie authored
1 require 'rubygems'
2 require 'rake'
3
4 begin
5 require 'jeweler'
6 Jeweler::Tasks.new do |gem|
7 gem.name = "faraday"
6656d37 @zenhob Added summary and desc to gemspec.
zenhob authored
8 gem.summary = "HTTP/REST API client library"
9 gem.description = "HTTP/REST API client library with pluggable components"
f6bf167 @technoweenie Initial commit to faraday.
technoweenie authored
10 gem.email = "technoweenie@gmail.com"
11 gem.homepage = "http://github.com/technoweenie/faraday"
12 gem.authors = ["rick"]
32ee0dc @jferris Depend on rack >= 1.0.1 to be compatible with actionpack 2.3.5
jferris authored
13 gem.add_dependency "rack", ">= 1.0.1"
990a28d @Flameeyes Allow newer addressable versions as well.
Flameeyes authored
14 gem.add_dependency "addressable", ">= 2.1.1"
f6bf167 @technoweenie Initial commit to faraday.
technoweenie authored
15 end
16 Jeweler::GemcutterTasks.new
67e2f47 @Flameeyes Only add check_dependencies as a test prerequisite when Jeweler is fo…
Flameeyes authored
17
18 task :test => :check_dependencies
f6bf167 @technoweenie Initial commit to faraday.
technoweenie authored
19 rescue LoadError
20 puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
21 end
22
23 require 'rake/testtask'
24 Rake::TestTask.new(:test) do |test|
25 test.libs << 'lib' << 'test'
5e05987 @technoweenie fix rake test pattern
technoweenie authored
26 test.pattern = 'test/**/*_test.rb'
f6bf167 @technoweenie Initial commit to faraday.
technoweenie authored
27 test.verbose = true
28 end
29
30 begin
31 require 'rcov/rcovtask'
32 Rcov::RcovTask.new do |test|
33 test.libs << 'test'
2db6886 @technoweenie add rack and addressable dependencies
technoweenie authored
34 test.pattern = 'test/**/*_test.rb'
f6bf167 @technoweenie Initial commit to faraday.
technoweenie authored
35 test.verbose = true
36 end
37 rescue LoadError
38 task :rcov do
39 abort "RCov is not available. In order to run rcov, you must: sudo gem install spicycode-rcov"
40 end
41 end
42
43 task :default => :test
44
45 require 'rake/rdoctask'
46 Rake::RDocTask.new do |rdoc|
47 version = File.exist?('VERSION') ? File.read('VERSION') : ""
48
49 rdoc.rdoc_dir = 'rdoc'
50 rdoc.title = "faraday #{version}"
51 rdoc.rdoc_files.include('README*')
52 rdoc.rdoc_files.include('lib/**/*.rb')
53 end
Something went wrong with that request. Please try again.