Skip to content
This repository has been archived by the owner. It is now read-only.

@ilg-ul ilg-ul released this Sep 27, 2019

QEMU has a new home in the xPack project:

To install the new versions, use:

$ xpm uninstall --global @xpack-dev-tools/qemu-arm

The GNU MCU Eclipse plug-ins were updated and since Sep. 2019 (v4.6.1) this name is also recognised. For older versions of the plug-ins, adjust the path manually.

Since there are xPacks referring to its binaries, this project will be preserved, at least for a while, but there will be no further changes, and the project will be archived.

Assets 2

@ilg-ul ilg-ul released this May 17, 2019 · 2 commits to gnuarmeclipse-dev since this release

Github Releases (by Release)

Version v2.8.0-6 20190517 is a maintenance release, to fix the bug affecting the graphical mode in GNU/Linux, introduced in the previous release.

Continue reading »

Easy install

QEMU is also available as an xPack and can be conveniently installed with xpm:

$ xpm install --global @gnu-mcu-eclipse/qemu@2.8.0-6.1

To install the latest version available, use:

$ xpm install --global @gnu-mcu-eclipse/qemu

Download analytics

Credit to Shields IO and Somsubhra/github-release-stats.

Assets 12

@ilg-ul ilg-ul released this Apr 24, 2019 · 3 commits to gnuarmeclipse-dev since this release

Github Releases (by Release)

Version v2.8.0-5 20190424 is a maintenance release, to fix several bugs.

Continue reading »

Known problems

  • the libSDL2-2.0.so.0 packed with the Linux binary was not build properly and QEMU does not start in graphical mode; as a workaround, remove the packed library and install it using the system packages manager, or use QEMU in non graphical mode.

Easy install

QEMU is also available as an xPack and can be conveniently installed with xpm:

$ xpm install --global @gnu-mcu-eclipse/qemu@2.8.0-5.1

To install the latest version available, use:

$ xpm install --global @gnu-mcu-eclipse/qemu

Download analytics

Credit to Shields IO and Somsubhra/github-release-stats.

Assets 12

@ilg-ul ilg-ul released this Feb 23, 2019 · 11 commits to gnuarmeclipse since this release

Github Releases (by Release)

Version v2.8.0-4-20190211 is a maintenance release, to fix a bug in the STM32F GPIO emulation.

Continue reading »

Easy install

QEMU is also available as an xPack and can be conveniently installed with xpm:

$ xpm install --global @gnu-mcu-eclipse/qemu@2.8.0-4.1

To install the latest version available, use:

$ xpm install --global @gnu-mcu-eclipse/qemu

Download analytics

Credit to Shields IO and Somsubhra/github-release-stats.

Assets 12

@ilg-ul ilg-ul released this May 23, 2018 · 49 commits to gnuarmeclipse-dev since this release

Github Releases (by Release)

Version 2.8.0-3-20180523 is a maintenance release, created using the new build scripts.

Continue reading »

Easy install

QEMU is also available as an xPack and can be conveniently installed with xpm:

$ xpm install --global @gnu-mcu-eclipse/qemu@2.8.0-3.1

To install the latest version available, use:

$ xpm install --global @gnu-mcu-eclipse/qemu

Note: The method to select the path based on the xPack version was already added to the Eclipse plug-in, but for now is only available in the version published on the test site (http://gnu-mcu-eclipse.netlify.com/v4-neon-updates-test/).

Assets 12

@ilg-ul ilg-ul released this Mar 1, 2017 · 56 commits to gnuarmeclipse-dev since this release

This is a maintenance release, adding a .tgz archive to the macOS distribution, required by the custom install used in the Travis CI scripts.

On March 2nd, the Debian archives were also recreated, to be consistent with the macOS hierarchy, which uses gnuarmeclipse/qemu/2.8.0-201702252154, with the gnuarmeclipse explicitly present.

There are no functional differences from the v2.8.0-20161227 release.

Github Releases (by Release)

Assets 10
Dec 23, 2016
2.7.1
Dec 20, 2016
v2.8.0 release
You can’t perform that action at this time.