Permalink
Browse files

git-addons: comment out broken subtree command presence check

Broken by Git 2.20.0 or 2.20.1.

Thanks to mz4wheeler for the notice.
  • Loading branch information...
pplx committed Jan 4, 2019
1 parent 57f336b commit 5b950c02bf6a646be3b0e39f1b362295a340beb1
Showing with 5 additions and 4 deletions.
  1. +5 −4 git-addons
@@ -386,10 +386,11 @@ check_requirements() {
if ! check_min_version "${GITVERSION}" "2.7"; then
print_warn "You are running git ${GITVERSION}; this script has not been tested with git version less than 2.7"
fi
if ! git --help --all | grep -q 'subtree'; then
print_error_req "git subtree command does not appear installed - upgrade git?"
return 2
fi
# FIXME: subtree command test broken since git 2.20.0 or .1, gone from list (?)
#if ! git --help --all | grep -q 'subtree'; then
# print_error_req "git subtree command does not appear installed - upgrade git?"
# return 2
#fi
if [ ! -e ".git/config" ]; then
print_error_req "This directory does not appear to be a git working copy - this script requires SCIPIO-ERP git repository"
return 2

0 comments on commit 5b950c0

Please sign in to comment.