Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 105 lines (65 sloc) 3.996 kb
73d33bd @imathis updated examples and added changelog
authored
1 # Fancy Buttons Changelog
2
f61c999 @imathis updated changelog for 1.0.1
authored
3 ## 1.1
4
5 - Fixed a bug in `fancy-button-text-colors` (it works now)
6
f64c70c @imathis Version bump to 1.0.0
authored
7 ## 1.0
33f2be5 @imathis disabled button style is not output by default, source refactored to imp...
authored
8
9 - **Changes that affect your current style**
10 - The mixin fancy-arrow was removed, I don't think anyone ever used this.
11 - Removed doubled border on :active state (caused lots of CSS bloat for minimal visual effect).
12 - Disabled styling is now off by default. `$fb-allow-disabled: false !default`. If you're using disabled styling, set this to true and you won't notice any changes. If not, your CSS output may be shrink quite a bit!
13 - **Improvements/Fixes**
14 - Disabled styles are much leaner
15 - Button reset uses `@extend` to make sure all fancy buttons get styles reset in one location
16 - New variable: `$fb-line-height: 1.2em !default` allows you to set a default button line-height.
17 - New Mixin: `disable-fancy-button` allows you to set the color and opacity for disabled button states. This is best used with a 'disabled' class name, or disabled attribute selector.
18 - Source is now dasherized (won't affect your usage, just makes it nicer for me)
f64c70c @imathis Version bump to 1.0.0
authored
19 - Imports to Compass library now only use the minimum necessary css3 modules
20 - Added support for RVM gem sets and bundler to aid development of fancy-buttons (doesn't affect users)
33f2be5 @imathis disabled button style is not output by default, source refactored to imp...
authored
21
c28058e @imathis added option to toggle output of disabled styles
authored
22 ## 0.5.5
62ec557 @imathis Example files have been removed. I'm going to add a guide instead for no...
authored
23
24 - Removed template files
33f2be5 @imathis disabled button style is not output by default, source refactored to imp...
authored
25 - Added `$fb-allow-disabled` variable - defaults to true (credit: Chris Eppstein)
c28058e @imathis added option to toggle output of disabled styles
authored
26 Now you can toggle the output of styling for disabled buttons or links with the class "button disabled".
27 This is useful if you want to reduce the size of your css and won't be using the disabled feature.
62ec557 @imathis Example files have been removed. I'm going to add a guide instead for no...
authored
28
024862a @imathis Version bump to 0.5.4
authored
29 ## 0.5.4
30
31 Updated old linear-gradient syntax in the example
32
156762a @imathis deprecated non-dasherized imports, added :visited style override for lin...
authored
33 ## 0.5.3
34
35 - Deprecated @import fancy_button.sass in favor of syntax agnostic and dashed import @import "fancy-buttons"
36 - Added :visited override to avoid incorrect colors in link buttons
37
38 ## 0.5.2
39
40 Updated requirements to include latest stable versions of Haml and Compass
41
0bf61c9 @imathis updated changelong, generated new gemspec
authored
42 ## 0.5.1
43
44 Fixed an overzealous .gitignore rule where essential stylesheets were being excluded from the gem. Oh my!
45
5504430 @imathis updated changelog and gemspec for 0.5.0 release
authored
46 ## 0.5
47
48 Updated to use Sass3 syntax, this requires the latest pre-releases of both Haml and Compass which should be automatically installed for you.
49
50 **Note: you may need to update your system with `sudo gem update --system` if you're not running ruby gems 1.3.6**
51
12ec03f @imathis updated gradients to work with the new Compass mixins supporting Firefox...
authored
52 ## 0.4
53
54 **Now Supporting the latest FireFox gradients**
55
56 Note: You'll need Compass 0.10 (pending release) or 0.10.0.pre8 (if you're bleeding edge like me)
57
58 ## 0.3.9
59
60 minor bug fixes
61
1260511 @imathis updated changelog
authored
62 ## 0.3.8
63
64 New:
65
66 * !fb\_image\_path allows users to specify an alternate image or image path than the default
67 * IE6 conditional stylesheet included (removes png background image)
68
69 ## 0.3.7
70
71 * Mundane fixes which I've forgotten.
72
57ab6ca @imathis updated changelog
authored
73 ## 0.3.6
74
75 New:
76
77 * CSS gradients can be disabled using !fb_gradient = 0 (mostly for testing purposes)
78
79 Fixes:
80
81 * Background color for buttons lighter than #aaa have been lightened to more closely match the gradient version.
82
83
910826d @imathis fixed version number in changelog
authored
84 ## 0.3.5
73d33bd @imathis updated examples and added changelog
authored
85
86 New:
87
88 * Use your own custom gradients (horizontal, vertical, or radial)!
89 * New matte gradient
90 * Improved gradient click style (looks inverted)
680fd68 @imathis fixed a typo in the changelog
authored
91 * Set project-wide gradient type !fb\_gradient\_type = "glossy", "matte", "custom" (default is glossy)
73d33bd @imathis updated examples and added changelog
authored
92 * Directly specify button padding with +fancy-button-padding(h\_padding, v\_padding, {border\_width})
93 * New demo showing glossy, matte, and custom gradients (includes a radial gradient demo)
94
95 Fixes:
96
97 * Fixed Text color flicker when using functions with borderline luminosity
98
99 Changes:
100
2281108 @imathis added info about instlaling compass --pre
authored
101 * **Important:** * You must use `sudo gem install compass --pre` since rubygems doesn't install prerelease gem versions automatically.
102 * **Important:** Global defaults have changed from the prefix "!default\_button\_" to the prefix "!fb_". If you were using global project defaults
73d33bd @imathis updated examples and added changelog
authored
103 update them or your buttons will break with this update. The reason for the change was to use a more specific namespace
104 to avoid global variable interactions.
105 * Now requiring Haml 2.2.14 and Compass 0.10.0.pre2 (for new gradient mixin)
Something went wrong with that request. Please try again.