New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

"Jekyll 2.0.3 | Error: Not a directory" when using jekyll_alias_generator #1610

Open
linduxed opened this Issue Jul 20, 2014 · 2 comments

Comments

Projects
None yet
3 participants
@linduxed

linduxed commented Jul 20, 2014

I just now rebased my blog code on top of the latest commit in master (c977b91) and apparently the latest version doesn't play well with the jekyll_alias_generator.

I have a couple of posts which I've made aliases for, so I don't know if it's just this one specific file with an alias that breaks or if it's many, but here's the error:

jekyll 2.0.3 | Error:  Not a directory @ rb_file_s_stat - /home/linduxed/Documents/blog/public/blog/2013/6/29/some-blog-post/index.html/

It could be that the plugin needs to be tweaked to work with Jekyll 2.x, but I wouldn't know.

@parkr

This comment has been minimized.

Collaborator

parkr commented Jul 20, 2014

@linduxed It looks like the jekyll-redirect-from plugin takes care of this same need. Can you try that and let us know if it suits your needs? https://github.com/jekyll/jekyll-redirect-from

@rahulpnath

This comment has been minimized.

rahulpnath commented Aug 9, 2016

For anyone reaching here now, looks like this issue is fixed in the plugin with the commit tsmango/jekyll_alias_generator@ff09231

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment