rake generate error:Yikes! It looks like you don't have jekyll-coffeescript or one of its dependencies installed. #1752

Open
jakoo opened this Issue Oct 23, 2015 · 3 comments

Projects

None yet

4 participants

@jakoo
jakoo commented Oct 23, 2015

This error came out after I used "rake generate". Adding gem 'json' to Gemfile doesn't help.

$ rake generate
## Generating Site with Jekyll
    write source/stylesheets/screen.css
  Dependency Error:  Yikes! It looks like you don't have jekyll-coffeescript or one of its dependencies installed. In order to use Jekyll as currently configured, you'll need to install this gem. The full error message from Ruby is: 'cannot load such file -- json/pure' If you run into trouble, you can find helpful resources at http://jekyllrb.com/help/! 
/home/username/.gem/ruby/gems/jekyll-2.5.3/lib/jekyll/deprecator.rb:56:in `rescue in block in gracefully_require': jekyll-coffeescript (Jekyll::Errors::MissingDependencyException)
    from /home/username/.gem/ruby/gems/jekyll-2.5.3/lib/jekyll/deprecator.rb:45:in `block in gracefully_require'
    from /home/username/.gem/ruby/gems/jekyll-2.5.3/lib/jekyll/deprecator.rb:44:in `each'
    from /home/username/.gem/ruby/gems/jekyll-2.5.3/lib/jekyll/deprecator.rb:44:in `gracefully_require'
    from /home/username/.gem/ruby/gems/jekyll-2.5.3/lib/jekyll.rb:166:in `<top (required)>'
    from /home/username/.gem/ruby/gems/jekyll-2.5.3/bin/jekyll:6:in `require'
    from /home/username/.gem/ruby/gems/jekyll-2.5.3/bin/jekyll:6:in `<top (required)>'
    from /home/username/bin/jekyll:23:in `load'
    from /home/username/bin/jekyll:23:in `<main>'
$ bundle show jekyll-coffeescript
/home/username/.gem/ruby/gems/jekyll-coffeescript-1.0.1

I'm using fedora20 + zsh. Anyone know how to solve this problem? Thanks in advance.

@erizhang
Contributor

Add gem 'json_pure' in the Gemfile, can resolve this issue.

@tvieira
tvieira commented Dec 11, 2015

Got the same problem with F22 and @erizhang solution solved it. Thanks.

@docsteveharris

@erizhang solved it for me too - thanks

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment