Skip to content
Permalink
Browse files

Update CircleCI image and config

  • Loading branch information
DarthSim committed Mar 19, 2020
1 parent e3cb533 commit 86a14b324302b1b16f903c07199692fd0e7eca16
Showing with 26 additions and 26 deletions.
  1. +2 −2 .circleci/Dockerfile
  2. +24 −24 .circleci/config.yml
@@ -1,4 +1,4 @@
FROM debian:stretch
FROM debian:buster

RUN apt-get -qq update \
&& apt-get install -y --no-install-recommends bash ca-certificates build-essential \
@@ -12,7 +12,7 @@ RUN \
mkdir /root/vips \
&& cd /root/vips \
&& curl -s -S -L -o vips_releases.json "https://api.github.com/repos/libvips/libvips/releases" \
&& for VIPS_VERSION in "8.6" "8.7" "8.8"; do \
&& for VIPS_VERSION in "8.7" "8.8" "8.9"; do \
mkdir $VIPS_VERSION \
&& export VIPS_RELEASE=$(grep -m 1 "\"tag_name\": \"v$VIPS_VERSION." vips_releases.json | sed -E 's/.*"v([^"]+)".*/\1/') \
&& echo "Building Vips $VIPS_RELEASE as $VIPS_VERSION" \
@@ -8,62 +8,62 @@ workflows:
- lint:
requires:
- checkout_code
go_version: "1.13"
vips_version: "8.8"
go_version: "1.14"
vips_version: "8.9"
- build:
name: go1.13_vips8.8
name: go1.14_vips8.9
requires:
- checkout_code
go_version: "1.13"
go_version: "1.14"
vips_version: "8.9"
- build:
name: go1.14_vips8.8
requires:
- checkout_code
go_version: "1.14"
vips_version: "8.8"
- build:
name: go1.13_vips8.7
name: go1.14_vips8.7
requires:
- checkout_code
go_version: "1.13"
go_version: "1.14"
vips_version: "8.7"
- build:
name: go1.13_vips8.6
name: go1.13_vips8.9
requires:
- checkout_code
go_version: "1.13"
vips_version: "8.6"
vips_version: "8.9"
- build:
name: go1.12_vips8.8
name: go1.13_vips8.8
requires:
- checkout_code
go_version: "1.12"
go_version: "1.13"
vips_version: "8.8"
- build:
name: go1.12_vips8.7
name: go1.13_vips8.7
requires:
- checkout_code
go_version: "1.12"
go_version: "1.13"
vips_version: "8.7"
- build:
name: go1.12_vips8.6
name: go1.12_vips8.9
requires:
- checkout_code
go_version: "1.12"
vips_version: "8.6"
vips_version: "8.9"
- build:
name: go1.11_vips8.8
name: go1.12_vips8.8
requires:
- checkout_code
go_version: "1.11.13"
go_version: "1.12"
vips_version: "8.8"
- build:
name: go1.11_vips8.7
name: go1.12_vips8.7
requires:
- checkout_code
go_version: "1.11.13"
go_version: "1.12"
vips_version: "8.7"
- build:
name: go1.11_vips8.6
requires:
- checkout_code
go_version: "1.11.13"
vips_version: "8.6"

executors:
imgproxy:

0 comments on commit 86a14b3

Please sign in to comment.
You can’t perform that action at this time.