Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

chore(deps): update dependency synckit to ^0.8.3 for yarn PnP #169

Merged
merged 1 commit into from Aug 17, 2022

Conversation

hanseo0507
Copy link
Contributor

I updated dependency sycnkit to from ^0.8.1 to ^0.8.3.
This is because synckit@^0.8.1 breaks using this pugin with Yarn PnP in VSCode.

This issue has already been reported(#164), and has been resolved in synckit(un-ts/synckit#98), but this plugin dependency has not been updated

@changeset-bot
Copy link

changeset-bot bot commented Aug 17, 2022

⚠️ No Changeset found

Latest commit: 4faa186

Merging this PR will not cause a version bump for any packages. If these changes should not result in a new version, you're good to go. If these changes should result in a version bump, you need to add a changeset.

This PR includes no changesets

When changesets are added to this PR, you'll see the packages that this PR includes changesets for and the associated semver types

Click here to learn what changesets are, and how to add one.

Click here if you're a maintainer who wants to add a changeset to this PR

@hanseo0507 hanseo0507 force-pushed the chore/update-synckit-to-0.8.3 branch from ce875a3 to 4faa186 Compare August 17, 2022 18:16
@codesandbox-ci
Copy link

This pull request is automatically built and testable in CodeSandbox.

To see build info of the built libraries, click here or the icon next to each commit SHA.

@JounQin
Copy link
Collaborator

JounQin commented Aug 17, 2022

You can upgrade synckit on your side manually AFAIK?

@hanseo0507
Copy link
Contributor Author

How can i upgrade synckit manually?

@JounQin
Copy link
Collaborator

JounQin commented Aug 17, 2022

How can i upgrade synckit manually?

  1. yarn upgrade synckit
  2. yarn remove eslint-import-resolver-typescript && yarn add -D eslint-import-resolver-typescript
  3. rm -rf yarn.lock && yarn
  4. Edit yarn.lock file, remove synckit@^0.8.1 section, and run yarn

@hanseo0507
Copy link
Contributor Author

I am testing in the Yarn Berry Monorepo environment.
As you said, I found a way to manually update directly from Yarn berry, and I executed it.

yarnPath: .yarn/releases/yarn-3.2.1.cjs
packageExtensions:
  'eslint-import-resolver-typescript@^3.4.0':
    dependencies:
      synckit: '^0.8.3'

Isn't it impossible to use it in Yarn PnP environment unless you upgrade it manually?

@JounQin
Copy link
Collaborator

JounQin commented Aug 17, 2022

Isn't it impossible to use it in Yarn PnP environment unless you upgrade it manually?

I tried in https://github.com/kriasoft/react-starter-kit, it seems true, so this PR is accepted.

In my imagine, when I remove "synckit@npm:^0.8.1" section in yarn.lock, yarn should reinstall the latest version of synckit, but it seems not true.

Copy link
Collaborator

@JounQin JounQin left a comment

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

@JounQin JounQin changed the title chore(deps): update dependency synckit to ^0.8.3 chore(deps): update dependency synckit to ^0.8.3 for yarn PnP Aug 17, 2022
@JounQin JounQin merged commit 973768d into import-js:master Aug 17, 2022
6 checks passed
@JounQin
Copy link
Collaborator

JounQin commented Aug 17, 2022

@hanseo0507 Thanks for your contribution!

@hanseo0507
Copy link
Contributor Author

@JounQin Thank you for reviewing my PR.
How many days will it take for this PR to be reflected in the release?

@hanseo0507 hanseo0507 deleted the chore/update-synckit-to-0.8.3 branch August 17, 2022 22:55
@JounQin
Copy link
Collaborator

JounQin commented Aug 17, 2022

@JounQin Thank you for reviewing my PR. How many days will it take for this PR to be reflected in the release?

Right now.

@hanseo0507
Copy link
Contributor Author

@JounQin Thank you for reviewing my PR. How many days will it take for this PR to be reflected in the release?

Right now.

Okay. Thank you!

@JounQin
Copy link
Collaborator

JounQin commented Aug 17, 2022

@hanseo0507

eslint-import-resolver-typescript@3.4.2 has been released! Thanks for your contribution again!

@noahnu
Copy link

noahnu commented Sep 1, 2022

For future reference, if using Yarn Modern, you can update a transitive dependency like synckit by running yarn up -R synckit. The newly released version matches the semantic version range ^0.8.1, so running yarn up -R synckit will bump the resolved version to the latest matching that range.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Development

Successfully merging this pull request may close these issues.

None yet

3 participants