New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Give 2.0] Donation Form doesn't work when downgrade from 2.0 to 1.8.17 #2465

Closed
emgk opened this Issue Dec 6, 2017 · 1 comment

Comments

Projects
None yet
3 participants
@emgk
Member

emgk commented Dec 6, 2017

Issue Overview

Donation forms ( created in Give version < 2.0 ) don't work when downgrading the plugin version from 2.0 [ after upgrading the database ] to less than version 2.0

Expected Behavior

Donation form created in Give version less than 2.0 should work properly when revert Give's old version plugin.

Current Behavior

Donation Form does not work when downgrade give version to 1.8.17 from Give 2.0 version.

Possible Solution

Steps to Reproduce (for bugs)

  1. Create donation form using Give 1.8.17.
  2. Update Give to 2.0
  3. Update the database.
  4. Revert Give plugin to 1.8.17
  5. Check that donation form in front-end, it will not work.

Related Issues and/or PRs

Todos

  • Tests
  • Documentation

WordPress Environment

``` ### WordPress Environment ###

Home URL: http://give20testt.dev
Site URL: http://give20testt.dev
WP Version: 4.9.1
WP Multisite: –
WP Memory Limit: 256 MB
WP Debug Mode: –
WP Cron: ✔
Language: en_US
Permalink Structure: /%year%/%monthnum%/%day%/%postname%/
Show on Front: posts
Table Prefix Length: 3
Table Prefix Status: Acceptable
Admin AJAX: Inaccessible
Registered Post Statuses: publish, future, draft, pending, private, trash, auto-draft, inherit, refunded, failed, revoked, cancelled, abandoned, processing, preapproval

Server Environment

Hosting Provider: DBH: localhost, SRV: give20testt.dev
TLS Connection: Connection uses TLS 1.2
TLS Connection: Probably Okay
Server Info: nginx/1.10.1
PHP Version: 5.3.29 - We recommend a minimum PHP version of 5.6. See: PHP Requirements in Give
PHP Post Max Size: 1,000 MB
PHP Time Limit: 900
PHP Max Input Vars: 3000
PHP Max Upload Size: 1,000 MB
cURL Version: 7.38.0, OpenSSL/1.0.2h - We recommend a minimum cURL version of 7.40.
SUHOSIN Installed: –
MySQL Version: 5.5.55 - We recommend a minimum MySQL version of 5.6. See: WordPress Requirements
Default Timezone is UTC: ✔
fsockopen/cURL: ✔
SoapClient: ✔
DOMDocument: ✔
gzip: ✔
GD Graphics Library: ✔
Multibyte String: ✔
Remote Post: ✔
Remote Get: ✔

Give Configuration

Give Version: 2.0.0
Upgraded From: –
Test Mode: Enabled
Currency Code: USD
Currency Position: Before
Decimal Separator: .
Thousands Separator: ,
Success Page: http://give20testt.dev/donation-confirmation/
Failure Page: http://give20testt.dev/donation-failed/
Donation History Page: http://give20testt.dev/donation-history/
Give Forms Slug: /donations/
Enabled Payment Gateways: Test Donation, Offline Donation
Default Payment Gateway: Test Donation
PayPal IPN Verification: Enabled
PayPal IPN Notifications: N/A
Admin Email Notifications: Disabled
Donor Email Access: Enabled

Session Configuration

Give Use Sessions: Enabled
Session: Disabled

Active Give Add-ons

Other Active Plugins

Inactive Plugins

Theme

Name: Twenty Seventeen
Version: 1.4
Author URL: https://wordpress.org/
Child Theme: No – If you're modifying Give on a parent theme you didn't build personally, then we recommend using a child theme. See: How to Create a Child Theme

</details>
@DevinWalker

This comment has been minimized.

Member

DevinWalker commented Dec 22, 2017

When you create a donation form in 2.0+ it will not be compatible with older versions.

  1. Always create a backup before upgrading
  2. Test once upgraded
  3. Inform yourself on the specifics of the upgrades: https://developers.givewp.com/2017/12/14/give-happens-downgrading-2-0-1-8/

@DevinWalker DevinWalker removed bug labels Dec 22, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment