Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

refactor: remove pre-2.0.0 code for backwards compatibility #3003

Closed
ravinderk opened this issue Apr 6, 2018 · 3 comments

Comments

Projects
None yet
3 participants
@ravinderk
Copy link
Collaborator

commented Apr 6, 2018

@DevinWalker This is information about backward compatibility code in core:

@ravinderk ravinderk changed the title dep(donation): remove backward compatibility for old meta key dep(donation): remove outdated backward compatibility Jan 11, 2019

@kevinwhoffman kevinwhoffman changed the title dep(donation): remove outdated backward compatibility refactor: remove outdated code for backwards compatibility Jan 11, 2019

@impress-org impress-org deleted a comment from ravinderk Jan 29, 2019

@ravinderk

This comment has been minimized.

Copy link
Collaborator Author

commented Feb 17, 2019

DevinWalker added a commit that referenced this issue Feb 19, 2019

Merge pull request #4002 from impress-org/issue/3003
refactor: remove outdated code for backwards compatibility #3003
@kevinwhoffman

This comment has been minimized.

Copy link
Member

commented Feb 20, 2019

Moving this back to Product Backlog so that we can address the remaining 2.0+ items at a later date.

@DevinWalker

This comment has been minimized.

Copy link
Member

commented May 8, 2019

We decided to focus 2.5.0 deprecation on >2.0.0 backward compatibility items. We are creating a new issue for the <2.0.0 items and will focus on those once more people have upgraded.

updated:
create a separate issue for backward compatibility <=2.0.0: #4096

@DevinWalker DevinWalker closed this May 8, 2019

@ravinderk ravinderk reopened this May 8, 2019

@ravinderk ravinderk closed this May 8, 2019

@DevinWalker DevinWalker changed the title refactor: remove outdated code for backwards compatibility refactor: remove pre-2.0.0 code for backwards compatibility Jun 11, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.