Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

fix: ensure Give blocks are compatible with latest Gutenberg #3697

Closed
Sidsector9 opened this issue Sep 19, 2018 · 4 comments

Comments

Projects
None yet
4 participants
@Sidsector9
Copy link
Member

commented Sep 19, 2018

Current Behavior

Currently none of the Give blocks work with Gutenberg 3.8.0 since Give is using certain JS functions which are deprecated in the latest Gutenberg version.

Expected Behavior

I expect all the Give Blocks to work with the latest Gutenberg version.

Steps to Reproduce

  1. Install Gutenberg 3.8.0
  2. Try to add any of the Give Blocks

None of the blocks show up.

Acceptance Criteria

  • Make Give Blocks compatible with latest Gutenberg version.
  • Test all the Give Blocks.
@mathetos

This comment has been minimized.

Copy link
Member

commented Sep 19, 2018

Just came here to make this issue myself.

@Sidsector9

This comment has been minimized.

Copy link
Member Author

commented Sep 26, 2018

Gutenberg 3.8.0 has deprecated the withAPIData function and replaced it with withSelect.

Implementation of withSelect requires the understanding of JavaScript's Promises, Generator Functions, yield expression and react-redux.

I'm facing a problem resolving the asynchronous response of wp.api.collections.Give_forms() to get the Form List added to the Form Block. Once this is fixed, this PR will be merge-ready.

Donor Wall and Form Grid Blocks are fixed and compatible with Gutenberg 3.8.0

I have discussed this with @ravinderk and he will be looking into this.

@kevinwhoffman kevinwhoffman changed the title fix: Make Give Blocks compatible with latest Gutenberg version fix: ensure Give blocks are compatible with latest Gutenberg Oct 5, 2018

@kevinwhoffman

This comment has been minimized.

Copy link
Member

commented Oct 24, 2018

@ravinderk WordPress 5.0 Beta 1 has released, so please make sure you are using it when developing the Give blocks. https://wordpress.org/news/2018/10/wordpress-5-0-beta-1/

@kevinwhoffman

This comment has been minimized.

Copy link
Member

commented Oct 30, 2018

After discussion with @ravinderk we are closing this in favor of a new issue with acceptance criteria relative to WP 5.0 Beta.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.