InaSAFE - QGIS plugin for estimating impact from natural disasters
Python TypeScript QML HTML C Shell Other
Pull request Compare This branch is 94 commits ahead, 28 commits behind develop.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
.github
.tx
bin
docs
extras
headless
i18n
realtime
resources
safe
safe_extras
scripts
.dockerignore
.gitattributes
.gitignore
.scrutinizer.yml
.travis.yml
71-apt-cacher-ng
AUTHORS.rst
CHANGELOG
Dockerfile
INSTALL.rst
LICENSE.txt
Makefile
README.md
REQUIREMENTS.txt
Vagrantfile
__init__.py
fabfile.py
metadata.txt
pylintrc
pylintrc_jenkins
qgis_testrunner.sh
run-env-linux.sh
run-env-osx.sh
run-env-realtime-test.sh
run-env-realtime.sh
run-gui-tests.bat
run-linux-pycharm.sh
run-make-linux.sh
run-make-osx.sh
run-osx-pycharm.sh
run-test-osx.sh
run-tests-win.bat
test_suite.py

README.md

InaSAFE

InaSAFE Screenshot

InaSAFE is free software that allows disaster managers to study realistic natural hazard impact scenarios for better planning, preparedness and response activities. InaSAFE is a plugin for QGIS.

For more information about InaSAFE and its documentation please visit inasafe.org.

The latest source code is available at https://github.com/inasafe/inasafe, which contains modules for risk calculations, GIS functionality and functions for impact modelling.

Story queue on Waffle:

  • Stories in Ready
  • Stories in In Progress

Throughput Graph

  • Current test status master: Build Status and Scrutinizer Code Quality

  • Current test status develop: Build Status and Scrutinizer Code Quality

PyPi Downloads for the 'safe' library (currently pip package is unmaintained):

  • PyPI version

Quick Installation Guide

You first need to have QGIS installed. Grab your free copy from the QGIS download page.

To install the InaSAFE plugin, use the plugin manager in QGIS:

Plugins → Manage and Install Plugins → Get more tab

Then search for "InaSAFE", select it and click the install button. The plugin will now be added to your plugins menu.

Note: You may need to restart QGIS if upgrading from a prior version.

Participation

We work under the philosophy that stakeholders should have access to the development and source code, and be able to participate in every level of the project - we invite comments, suggestions and contributions. See our milestones list and our open issues list for known bugs and outstanding tasks. You can also chat live with our developers and community members using the link below.

Join the chat at https://gitter.im/AIFDR/inasafe

System Requirements

  • A standard PC with at least 4GB of RAM running Windows, Linux or Mac OS X
  • The QGIS Open Source Geographic Information System (http://www.qgis.org). Although InaSAFE will probably run on any version of QGIS version above 2.0 or newer, our supported version is the latest Long Term Release version of QGIS.

History

  • In March 2011, Risk In A Box (the predecessor to InaSAFE) was built as a web application running as a GeoNode Plugin.
  • InaSAFE development as a QGIS plugin started in January 2012.
  • In October 2012, version 1.0 of InaSAFE was launched at the 5th Asian ministerial conference on disaster risk reduction (AMCDRR) where it was demonstrated to the then president of Indonesia, Susilo Bambang Yudhoyono who praised the project.
  • On 30 Jan 2013, InaSAFE was awarded the prestigious Black Duck Open Source. Rookie of the Year Award.
  • Version 2.0 of InaSAFE was released in January, 2014.
  • Version 3.0 was released in March 2015 which added support for using the QGIS API within impact functions.

Disclaimer

InaSAFE has been jointly developed by the Indonesian Government-BNPB, the Australian Government, the World Bank-GFDRR and independent contributors. These agencies and the individual software developers of InaSAFE take no responsibility for the correctness of outputs from InaSAFE or decisions derived as a consequence.

License

InaSAFE is free software: you can redistribute it and/or modify it under the terms of the GNU General Public License version 3 (GPLv3) as published by the Free Software Foundation.

The full GNU General Public License is available in LICENSE.txt or http://www.gnu.org/licenses/gpl.html

Disclaimer of Warranty (GPLv3)

There is no warranty for the program, to the extent permitted by applicable law. Except when otherwise stated in writing the copyright holders and/or other parties provide the program "as is" without warranty of any kind, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The entire risk as to the quality and performance of the program is with you. Should the program prove defective, you assume the cost of all necessary servicing, repair or correction.

Limitation of Liability (GPLv3)

In no event unless required by applicable law or agreed to in writing will any copyright holder, or any other party who modifies and/or conveys the program as permitted above, be liable to you for damages, including any general, special, incidental or consequential damages arising out of the use or inability to use the program (including but not limited to loss of data or data being rendered inaccurate or losses sustained by you or third parties or a failure of the program to operate with any other programs), even if such holder or other party has been advised of the possibility of such damages.

Thank you

PyCharm

We use PyCharm for our python development work

JetBrains kindly sponsor the licenses for InaSAFE under their 'free for open source projects' programme. Please support them by buying a professional license if you are able to!