Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 199 lines (120 sloc) 4.843 kb
7839114 @JangoSteve Version 2.0.2
JangoSteve authored
1 ## 2.0.2 (03 April 2012)
2
3 - Updated to jQuery 1.7.2
4 - Updated to jQuery UI 1.8.18
5 - Updated to latest jquery-ujs
6 - Override provided for obtaining `href`
7 - Edit `crossDomain` and `dataType` from `ajax:before` event
8
21af08e @JangoSteve Version 2.0.1
JangoSteve authored
9 ## 2.0.1 (28 February 2012)
10
11 - Fixed Rails 3.2 dependency issue
12
13 ## 2.0 (20 December 2011)
14
15 - Minimum dependency set to Rails 3.2
16
174d415 @JangoSteve Version 1.0.19
JangoSteve authored
17 ## 1.0.19 (26 November 2011)
18
19 - Updated to jQuery 1.7.1
20 - Updated to latest jquery-ujs
21 - Fixed disabled links to re-enable when `ajax:before` or
22 `ajax:beforeSend` are canceled
23 - Switched from deprecated `live` to `delegate`
24
546029a @JangoSteve Version 1.0.18
JangoSteve authored
25 ## 1.0.18 (18 November 2011)
26
27 - Updated to latest jquery-ujs
28 - Fixed event parameter for form submit event handlers in IE for
29 jQuery 1.6.x
30 - Fixed form submit event handlers for jQuery 1.7
31
f32e9ec @JangoSteve Version 1.0.17
JangoSteve authored
32 ## 1.0.17 (9 November 2011)
33
34 - Updated to jQuery 1.7
35 - Updated to latest jquery-ujs
36 - Moved file comment above function so it won't be included in
37 compressed version
38
a68b34b @JangoSteve Version 1.0.16
JangoSteve authored
39 ## 1.0.16 (12 October 2011)
40
41 - Updated to jQuery 1.6.4
42 - Updated to jQuery UI 1.8.16
43
2a36aaa @JangoSteve Version 1.0.15
JangoSteve authored
44 ## 1.0.15 (12 October 2011)
45
46 - Updated to latest jquery-ujs
47 - Fixed formInputClickSelector `button[type]` for IE7
48 - Copy target attribute to generated form for `a[data-method]` links
49 - Return true (abort ajax) for ctrl- and meta-clicks on remote links
50 - Use jQuery `.prop()` for disabling/enabling elements
51
56c4445 @JangoSteve Version 1.0.14
JangoSteve authored
52 ## 1.0.14 (08 September 2011)
53
54 - Updated to latest jquery-ujs
55 - Added `disable-with` support for links
56 - minor bug fixes
57 - Added `data-remote` support for change events of all input types
58 - Added install generator for Rails 3.1 with instructional message
59
07dd7c6 @JangoSteve Version 1.0.13
JangoSteve authored
60 ## 1.0.13 (11 August 2011)
61
62 - Updated to latest jquery-ujs with `novalidate` support
63 - No more support for jquery older than v1.6
64
8f0923d @JangoSteve Version 1.0.12
JangoSteve authored
65 ## 1.0.12 (23 June 2011)
66
07dd7c6 @JangoSteve Version 1.0.13
JangoSteve authored
67 - Updated to latest jquery-ujs with 'blank form action' and
8f0923d @JangoSteve Version 1.0.12
JangoSteve authored
68 data-remote support for select elements
69
d8293db @JangoSteve Version 1.0.11
JangoSteve authored
70 ## 1.0.11 (15 June 2011)
71
72 - Updated to latest jqueyr-ujs with cross-domain support
73
74 [See jquery-ujs issue 167](https://github.com/rails/jquery-ujs/pull/167) for relevant discussion
75
671826b @JangoSteve Version 1.0.10
JangoSteve authored
76 ## 1.0.10 (13 June 2011)
77
78 - Updated to latest jqueyr-ujs with bug fixes
79
6b4417c @JangoSteve Version 1.0.9
JangoSteve authored
80 ## 1.0.9 (25 May 2011)
81
82 - Merged with new rails repo (3.1 fix)
83
80afd5d @JangoSteve Version 1.0.8
JangoSteve authored
84 ## 1.0.8 (25 May 2011)
85
86 - Updated to latest jquery-ujs with `[disabled][required]` fix
87
3a8007f @indirect Version 1.0.7
authored
88 ## 1.0.7 (21 May 2011)
89
90 - Fix assert_select_jquery's bad call to unescape_rjs
91
2135679 @JangoSteve Version 1.0.6
JangoSteve authored
92 ## 1.0.6 (21 May 2011)
93
94 - Updated to latest jquery-ujs with `data-params` support
95
96 ## 1.0.5 (17 May 2011)
406f351 @JangoSteve Version 1.0.5
JangoSteve authored
97
98 - Updated to latest jquery-ujs
99 - Remove old rails.js in Rails 3.0 generator
100
8b1a80d @indirect Version 1.0.4
authored
101 ## 1.0.4 (17 May 2011)
102
103 - Fix exception in Rails 3.0 generator
104
a4d01e9 @indirect Version 1.0.3
authored
105 ## 1.0.3 (17 May 2011)
106
107 - Update to jQuery 1.6.1
108 - Remove useless --version generator option
109
66ff41e @indirect Version 1.0.2
authored
110 ## 1.0.2 (12 May 2011)
111
112 - Fix Rails 3.0 now that rails.js is named jquery_ujs.js
113
0f1f809 @indirect Version 1.0.1
authored
114 ## 1.0.1 (10 May 2011)
115
116 - Stop downloading rails.js from GitHub
117 - Vendor jQuery UI for those who want it
118 - Fix assert_select_jquery now that Rails 3.1 has no RJS at all
119 - Fix rails dependency to just be railties
120
121 ## 1.0.rc (3 May 2011)
7f67832 @indirect Rails 3.1 and asset pipelines
authored
122
123 - Rails 3.1 asset pipeline edition
124 - Removes generators and railties
125 - Just provides jquery.js and jquery_ujs.js
0f1f809 @indirect Version 1.0.1
authored
126 - Still compatible with Rails 3.0 via the old generator code
7f67832 @indirect Rails 3.1 and asset pipelines
authored
127
20f31db @indirect Version 0.2.7 for jQuery 1.5
authored
128 ## 0.2.7 (5 February 2011)
129
130 - Updated to use jQuery 1.5 by default
131
350e626 @indirect bump to 0.2.6
authored
132 ## 0.2.6 (1 December 2010)
133
134 Feature:
135
136 - Updated to use jQuery 1.4.4 by default
137
59a6fee @indirect Version 0.2.5
authored
138 ## 0.2.5 (4 November 2010)
139
140 Bugfix:
141
142 - Download JQuery Rails UJS via HTTPS since Github is now HTTPS only
143
45c87b1 @indirect Version 0.2.4, changelog for 0.2.3 and 0.2.4
authored
144 ## 0.2.4 (16 October 2010)
145
146 Features:
147
148 - Updated to use the new jQuery 1.4.3 by default, with the IE .live() bug fixed
149 - Always download the newest 1.x release of jQuery UI
150 - Try to install unknown versions of jQuery, with fallback to the default
151 - Print informative messages in the correct Generator style
152
153 ## 0.2.3 (13 October 2010)
154
155 Features:
156
157 - Support Edge Rails 3.1 by depending on Rails ~>3.0
158 - Add Sam Ruby's assert_select_jquery test helper method
159 - Use jquery.min only in production (and not in the test env)
160
9e3d323 @indirect Epiphany time: I expect the Railtie API to work for all 3.x releases.…
authored
161 ## 0.2.2 (8 October 2010)
162
163 Feature:
164
165 - Depend on Rails >=3.0 && <4.0 for edge Rails compatibility
166
21a8e5b @indirect Update changelog for 0.2.1
authored
167 ## 0.2.1 (2 October 2010)
168
169 Bugfix:
170
171 - Default to jQuery 1.4.1 as recommended by jQuery-ujs
172 due to a bug in 1.4.2 (http://jsbin.com/uboxu3/7/)
173
174 ## 0.2 (2 October 2010)
175
176 Features:
177
178 - Allow specifying which version of jQuery to install
179 - Add generator tests (thanks, Louis T.)
180 - Automatically use non-minified JS in development mode
181
e91e812 @indirect Version 0.1.3, now with changelog
authored
182 ## 0.1.3 (16 September 2010)
183
184 Bugfix:
185
186 - allow javascript :defaults tag to be overridden
187
188 ## 0.1.2 (18 August 2010)
189
190 Bugfix:
191
192 - check for jQueryUI in the right place
193
194 ## 0.1.1 (16 August 2010)
195
196 Bugfix:
197
8ec55b3 @JangoSteve Updated to latest jquery-ujs with ajax:aborted:required fix for non-r…
JangoSteve authored
198 - fix generator by resolving namespace conflict between Jquery::Rails and ::Rails
Something went wrong with that request. Please try again.