Permalink
Browse files

cleanup gemspec, readme, and changelog

  • Loading branch information...
1 parent dffd3b0 commit 56ee87442b87f0edef037fdc995a9f76af2bee83 @negonicrac negonicrac committed Sep 10, 2012
Showing with 35 additions and 40 deletions.
  1. +9 −9 CHANGELOG.rdoc
  2. +2 −2 Gemfile
  3. +3 −2 Gemfile.lock
  4. +3 −3 README.rdoc
  5. +5 −6 Rakefile
  6. +13 −18 rails3-generators.gemspec
View
@@ -19,17 +19,17 @@
* MongoMapper provides find(id), not first(id).
See http://stackoverflow.com/questions/4646745 (Semyon Perepelitsa)
-== 0.17.0
+== 0.17.0
* enhancements
* Added a generator for creating models with no persistent.
They still include ActiveModel::Validations and ActiveModel::Serialization.
-
+
When generating properties you can use the following as types to create the required accessor
-
+
read - generate read_accessor
write - generate write_accessor
all - generate attr_accessor
-
+
(Colin Gemmel)
== 0.16.0
@@ -48,7 +48,7 @@
== 0.14.0
* enhancements
* added Fabricator
-
+
== 0.13.0
* optimize
* The Haml generators have moved to {the haml-rails gem}[http://github.com/indirect/haml-rails].
@@ -66,11 +66,11 @@
* enhancements
* Added new mongo_mapper generator for mongo mapper 0.8 with lots of extra features [Kristian Mandrup]
* Added mongoid generator for mongoid 2.0.beta with features similar to new mongo_mapper [Kristian Mandrup]
-
+
* optimize
* renamed datamapper to data_mapper
* renamed mongomapper to mongo_mapper.
-
+
* fix
* added DataMapper Tests
* added MongoMapper Tests
@@ -93,7 +93,7 @@
* added mustache:install
* added mustache:controller
* added mustache:scaffold
-
+
* fix
* fixed shoulda controller CamelCase problem.
@@ -140,4 +140,4 @@
* shoulda:controller
* shoulda:model
- * simple_form:scaffold
+ * simple_form:scaffold
View
@@ -1,3 +1,3 @@
-source :gemcutter
+source "https://rubygems.org"
-gemspec
+gemspec
View
@@ -1,11 +1,11 @@
PATH
remote: .
specs:
- rails3-generators (0.17.3)
+ rails3-generators (0.17.4)
railties (>= 3.0.0)
GEM
- remote: http://rubygems.org/
+ remote: https://rubygems.org/
specs:
abstract (1.0.0)
actionmailer (3.0.3)
@@ -87,4 +87,5 @@ DEPENDENCIES
haml-rails
rails (>= 3.0.0)
rails3-generators!
+ rake
test-unit
View
@@ -8,7 +8,7 @@ Rails 3 compatible generators for gems that don't have them yet
and add the following to your project's Gemfile
- gem 'rails3-generators'
+ gem "rails3-generators"
== Notes/Use
@@ -45,6 +45,6 @@ To avoid overriding the rails built-in Erb template generators this project uses
and more[http://github.com/indirect/rails3-generators/contributors]
-==License
+== License
-Ruby license or MIT license, take your pick
+Ruby license or MIT license, take your pick
View
@@ -1,12 +1,11 @@
# -*- encoding: utf-8 -*-
-require 'bundler'
-Bundler::GemHelper.install_tasks
+require "bundler/gem_tasks"
-require 'rake/testtask'
+require "rake/testtask"
Rake::TestTask.new(:test) do |test|
- test.libs << 'lib' << 'test'
- test.pattern = 'test/**/*_test.rb'
+ test.libs << "lib" << "test"
+ test.pattern = "test/**/*_test.rb"
test.verbose = true
end
-task :default => :test
+task :default => :test
View
@@ -1,42 +1,37 @@
# -*- encoding: utf-8 -*-
-require File.expand_path('../lib/rails3-generators/version', __FILE__)
+require File.expand_path("../lib/rails3-generators/version", __FILE__)
Gem::Specification.new do |s|
- s.name = 'rails3-generators'
+ s.name = "rails3-generators"
s.version = Rails3::Generators::VERSION
s.platform = Gem::Platform::RUBY
s.authors = ["Jose Valim", "Anuj Dutta", "Paul Berry", "Jeff Tucker", "Louis T.", "Jai-Gouk Kim", "Darcy Laycock", "Peter Haza", "Peter Gumeson", "Kristian Mandrup", "Alejandro Juarez"]
- s.email = 'andre@arko.net'
- s.homepage = 'https://github.com/indirect/rails3-generators'
- s.summary = 'Rails 3 compatible generators'
+ s.email = "andre@arko.net"
+ s.homepage = "https://github.com/indirect/rails3-generators"
+ s.summary = "Rails 3 compatible generators"
s.description = "Rails 3 compatible generators for gems that don't have them yet "
- s.rubyforge_project = 'rails3-generators'
+ s.rubyforge_project = "rails3-generators"
s.required_rubygems_version = ">= 1.3.6"
-
+
s.add_dependency "railties", ">= 3.0.0"
s.add_development_dependency "bundler", ">= 1.0.0"
+ s.add_development_dependency "rake"
s.add_development_dependency "test-unit"
s.add_development_dependency "haml-rails"
s.add_development_dependency "rails", ">= 3.0.0"
s.add_development_dependency "factory_girl"
-
+
s.files = `git ls-files`.split("\n")
s.executables = `git ls-files`.split("\n").select{|f| f =~ /^bin/}
- s.require_path = 'lib'
+ s.require_path = "lib"
+
+ s.extra_rdoc_files = ["README.rdoc", "CHANGELOG.rdoc"]
- s.extra_rdoc_files = ['README.rdoc', 'CHANGELOG.rdoc']
-
s.post_install_message = %Q{
rails3-generators-#{Rails3::Generators::VERSION}
Be sure to check out the wiki, https://wiki.github.com/indirect/rails3-generators/,
for information about recent changes to this project.
-
-Machinist generators have been removed. Please update your project to use Machinist 2 (https://github.com/notahat/machinist) which contains its own generators.
-
-Fabrication generators have been removed. Please update your project to use Fabrication (https://github.com/paulelliott/fabrication) which contains its own generators.
-
-Mongoid generators have been removed. Please update your project to use Mongoid (https://github.com/mongoid/mongoid) which contains its own generators.
}
-end
+end

0 comments on commit 56ee874

Please sign in to comment.