This repository has been archived by the owner. It is now read-only.

File to import not found or unreadable: compass/css3. (Sass::SyntaxError) #34

Open
gforghetti opened this Issue May 14, 2014 · 9 comments

Comments

Projects
None yet
8 participants
@gforghetti
Copy link

gforghetti commented May 14, 2014

Getting the error "File to import not found or unreadable: compass/css3. (Sass::SyntaxError)" running the command "keydown slides slides.md".

Just installed keydown, generated a new project and the the "keydown slides slides.md" command.

Any ideas what's wrong?

OS Mac 10.9.2
ruby 2.0.0p451 (2014-02-24 revision 45167) [universal.x86_64-darwin13]
compass (1.0.0.alpha.19)
compass-core (1.0.0.alpha.19)
compass-import-once (1.0.4)

Gary

@jbenet

This comment has been minimized.

Copy link

jbenet commented May 15, 2014

same here. :(

@jrab89

This comment has been minimized.

Copy link

jrab89 commented May 27, 2014

I'm getting the same error

@AndyNovo

This comment has been minimized.

Copy link

AndyNovo commented Aug 25, 2014

I suspect that this would be fixed by having the compass dependency be set to 0.13.alpha.4 as it seems the issue is a hard coded path to css3 (and some deprecated box thing).

@gforghetti

This comment has been minimized.

Copy link

gforghetti commented Aug 25, 2014

I uninstalled compass 1.0.1 and installed compass 0.12.7 and all is well.

Setting the dependency is a better way. Thanks Andy.

@cunnie

This comment has been minimized.

Copy link

cunnie commented Aug 28, 2014

Thanks @gforghetti 👍

I used the following Gemfile:

source 'https://rubygems.org'

gem 'keydown'
gem 'compass', '0.12.7'

and then I was able to make it work:

bundle
bundle exec keydown slides slides.md
@gimbo

This comment has been minimized.

Copy link

gimbo commented Dec 1, 2014

Still broken.

@gforghetti

This comment has been minimized.

Copy link

gforghetti commented Dec 1, 2014

Uninstall compass and install compass 0.12.7

@samuelbarbosaa

This comment has been minimized.

Copy link

samuelbarbosaa commented Dec 15, 2014

sudo gem uninstall compass
sudo gem install compass -v 0.12.7

@ajdfajdfl2003

This comment has been minimized.

Copy link

ajdfajdfl2003 commented Apr 21, 2016

Thanks! @samuelbarbosaa

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.