Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Telegraf startup -- retry failed server connections #187

Closed
gotyaoi opened this issue Sep 11, 2015 · 0 comments
Closed

Telegraf startup -- retry failed server connections #187

gotyaoi opened this issue Sep 11, 2015 · 0 comments
Labels
bug

Comments

@gotyaoi
Copy link
Contributor

@gotyaoi gotyaoi commented Sep 11, 2015

An issue I've noticed is that if the agent is unable to connect to an output initially, it exits. This came up on a restart of our server which runs influxdb. This server (Centos 6) also runs a telegraf agent. Both influxdb and telegraf were configured to start on boot, however, it appears that when telegraf started, influxdb was not ready to talk, so telegraf logged an error and exited. It might be good for telegraf to have a back-off and retry strategy for initially connecting to outputs.

@sparrc sparrc changed the title Connection Retry Telegraf start -- retry failed server connections Sep 11, 2015
@sparrc sparrc changed the title Telegraf start -- retry failed server connections Telegraf startup -- retry failed server connections Sep 11, 2015
@sparrc sparrc added the bug label Sep 11, 2015
@sparrc sparrc closed this in 82d9141 Sep 19, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.