Permalink
Browse files

funking jeweler. Got a jruby dependency out of the gemspec

  • Loading branch information...
1 parent 05bb05b commit 23c533ca59a1c8977ba3fb4fd5de905521c74569 Philip (flip) Kromer committed Aug 13, 2012
Showing with 2 additions and 6 deletions.
  1. +2 −2 Gemfile
  2. +0 −4 configliere.gemspec
View
@@ -3,8 +3,8 @@ source 'http://rubygems.org'
gem 'multi_json', ">= 1.1"
# Only necessary if you want to use Configliere::Prompt
-gem 'highline', ">= 1.5.2", :require => false # unless (defined?(JRUBY_VERSION) && (JRUBY_VERSION >= "1.7.0"))
-gem 'jruby-openssl', :platform => [:jruby]
+gem 'highline', ">= 1.5.2", :require => false
+gem 'jruby-openssl', :platform => [:jruby] if RUBY_PLATFORM =~ /java/
# Only gems that you want listed as development dependencies in the gemspec
group :development do
View
@@ -62,7 +62,6 @@ Gem::Specification.new do |s|
"spec/configliere/commands_spec.rb",
"spec/configliere/config_block_spec.rb",
"spec/configliere/config_file_spec.rb",
- "spec/configliere/crypter_spec.rb",
"spec/configliere/deep_hash_spec.rb",
"spec/configliere/define_spec.rb",
"spec/configliere/encrypted_spec.rb",
@@ -85,7 +84,6 @@ Gem::Specification.new do |s|
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<multi_json>, [">= 1.1"])
s.add_runtime_dependency(%q<highline>, [">= 1.5.2"])
- s.add_runtime_dependency(%q<jruby-openssl>, [">= 0"])
s.add_development_dependency(%q<bundler>, ["~> 1.1"])
s.add_development_dependency(%q<rake>, [">= 0"])
s.add_development_dependency(%q<yard>, [">= 0.7"])
@@ -94,7 +92,6 @@ Gem::Specification.new do |s|
else
s.add_dependency(%q<multi_json>, [">= 1.1"])
s.add_dependency(%q<highline>, [">= 1.5.2"])
- s.add_dependency(%q<jruby-openssl>, [">= 0"])
s.add_dependency(%q<bundler>, ["~> 1.1"])
s.add_dependency(%q<rake>, [">= 0"])
s.add_dependency(%q<yard>, [">= 0.7"])
@@ -104,7 +101,6 @@ Gem::Specification.new do |s|
else
s.add_dependency(%q<multi_json>, [">= 1.1"])
s.add_dependency(%q<highline>, [">= 1.5.2"])
- s.add_dependency(%q<jruby-openssl>, [">= 0"])
s.add_dependency(%q<bundler>, ["~> 1.1"])
s.add_dependency(%q<rake>, [">= 0"])
s.add_dependency(%q<yard>, [">= 0.7"])

0 comments on commit 23c533c

Please sign in to comment.