Wonderdog with Hadoop2/YARN #20

Open
murdockcrc opened this Issue Jan 12, 2014 · 1 comment

Comments

Projects
None yet
2 participants
@murdockcrc

I compiled Pig to use Hadoop2.2.0 and installed ElasticSearch and Wonderdog. Running a Pig job in this setup fails with the following error:

"java.lang.IncompatibleClassChangeError: Found interface org.apache.hadoop.mapreduce.TaskAttemptContext, but class was expected
at org.apache.hadoop.mapred.LocalJobRunner$Job.run(LocalJobRunner.java:403)"

I was wondering if there is way to build Wonderdog for it to work with Hadoop2/YARN.

Thanks

@margaretlange

This comment has been minimized.

Show comment Hide comment
@margaretlange

margaretlange Oct 20, 2014

I was able to get rid of this kind of error by recreating the Wonderdog project with the dependency in the pom.xml file updated. Change the artifact id to "hadoop-client" and the version to "2.2.0."

I was able to get rid of this kind of error by recreating the Wonderdog project with the dependency in the pom.xml file updated. Change the artifact id to "hadoop-client" and the version to "2.2.0."

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment