Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Wonderdog doesn't work with 0.19.0, as the APIs have changed #3

Closed
rjurney opened this Issue Mar 17, 2012 · 6 comments

Comments

Projects
None yet
4 participants
Contributor

rjurney commented Mar 17, 2012

No description provided.

Contributor

kornypoet commented Mar 17, 2012

@rjurney Can you provide any assistance with reconciling to the new version?

Contributor

rjurney commented Mar 17, 2012

Yes, when I have the brain power. Java makes me cry.

Contributor

kornypoet commented Apr 9, 2012

It appears @joearasin has made this possible.
See commit: 17784eb

@kornypoet kornypoet closed this Apr 9, 2012

Contributor

joearasin commented Apr 9, 2012

I think 0.19 is different from 0.18.7, but don't quote me on it.

@kornypoet kornypoet reopened this Apr 9, 2012

Contributor

kornypoet commented Apr 9, 2012

@joearasin is right, 0.19.0.RC1 makes another breaking change to the API. It's minor, and we are still using 18.7, so I am not going to patch Wonderdog right away. @rjurney if you look at @joearasin's commit you should see the relevant changes, and this link has the new class names: http://www.elasticsearch.org/download/2012/02/07/0.19.0.RC1.html

I will (soon) create versioned branches of Wonderdog to match Elasticsearch's versions, and that will also address the issue.

Owner

mrflip commented Mar 2, 2013

Closed by #8, I believe

@mrflip mrflip closed this Mar 2, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment