Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[BUG] Botkube sends slack notifications multiple times for an event #181

Closed
mstrYoda opened this issue Sep 17, 2019 · 6 comments
Labels
bug

Comments

@mstrYoda
Copy link

@mstrYoda mstrYoda commented Sep 17, 2019

Describe the bug
I've delete a statefulset via helm and slack notification sent by botkube. But I watch the channel and it keeps sending notifications.

Botkube puts the time to the footer of notification as follows:
BotKube | Today at 1:25 PM

But even latest notifications at 2:14 PM contain same footer "BotKube | Today at 1:25 PM".

When I type kubectl get events there is not any event which recently happened to send
notification to slack.

To Reproduce
Steps to reproduce the behavior:
I am not sure how to reproduce this behavior.

Expected behavior
It should only send one time notification.

Screenshots
Screen Shot 2019-09-17 at 14 24 08
Screen Shot 2019-09-17 at 14 24 14

@mstrYoda mstrYoda added the bug label Sep 17, 2019
@PrasadG193

This comment has been minimized.

Copy link
Member

@PrasadG193 PrasadG193 commented Sep 17, 2019

@mstrYoda What version of BotKube you are using? You can get version with @BotKube version command.

@mstrYoda

This comment has been minimized.

Copy link
Author

@mstrYoda mstrYoda commented Sep 17, 2019

Output of the command is "BotKube version: v0.8.0"

@PrasadG193

This comment has been minimized.

Copy link
Member

@PrasadG193 PrasadG193 commented Sep 17, 2019

@mstrYoda I think this is already fixed in the develop branch. Could you please try deploying BotKube with latest image. You can use the following commands to use latest helm chart

$ helm repo add infracloudio https://infracloudio.github.io/charts
$ helm repo update
$ helm install  --version v9.99.9-dev --name botkube --namespace botkube \
--set config.communications.slack.enabled=true \
--set config.communications.slack.channel=<SLACK_CHANNEL_NAME> \
--set config.communications.slack.token=<SLACK_API_TOKEN_FOR_THE_BOT> \
--set config.settings.clustername=<CLUSTER_NAME> \
--set config.settings.allowkubectl=<ALLOW_KUBECTL> \
--set image.repository=infracloud/botkube \
--set image.tag=latest \
infracloudio/botkube
@PrasadG193

This comment has been minimized.

Copy link
Member

@PrasadG193 PrasadG193 commented Sep 20, 2019

@mstrYoda Please let us know if you see the problem in develop branch also

@mstrYoda

This comment has been minimized.

Copy link
Author

@mstrYoda mstrYoda commented Sep 20, 2019

I've deployed botkube into our dev environment with specified configuration above. I will update my observation here when I deploy to production.

@mstrYoda

This comment has been minimized.

Copy link
Author

@mstrYoda mstrYoda commented Nov 19, 2019

I've tested it and observed that no longer get duplicate events.

@mstrYoda mstrYoda closed this Nov 19, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.