Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[BUG] BotKube redundant error messages when deployed in multicluster #230

Closed
PrasadG193 opened this issue Dec 19, 2019 · 3 comments
Closed

[BUG] BotKube redundant error messages when deployed in multicluster #230

PrasadG193 opened this issue Dec 19, 2019 · 3 comments
Assignees
Labels
bug good first issue

Comments

@PrasadG193
Copy link
Member

@PrasadG193 PrasadG193 commented Dec 19, 2019

Describe the bug
When BotKube is deployed in multiple cluster with settings.allowkubectl:false set in the config, it returns redundant error messages when BotKube commands are executed.

Sample messages (provided by an user on BotKube slack)

Sorry, the admin hasn't given me the permission to execute kubectl command on cluster 'cluster-0hyv0'.
Sorry, the admin hasn't given me the permission to execute kubectl command on cluster 'cluster-0253f'.
Sorry, the admin hasn't given me the permission to execute kubectl command on cluster 'cluster-6toxk'.
Sorry, the admin hasn't given me the permission to execute kubectl command on cluster 'cluster-08cka'.
Cluster: cluster-mx8ae
No resources found in default namespace.

To Reproduce
Steps to reproduce the behavior:

  1. Deploy BotKube on multiple clusters with the same token
  2. Execute @BotKube get pods command

Expected behavior
BotKube should get response only from the cluster which is configured for the channel or whose name is passed with --cluster-name flag

@PrasadG193 PrasadG193 added bug good first issue labels Dec 19, 2019
@mbtamuli
Copy link

@mbtamuli mbtamuli commented Dec 26, 2019

I would like to work on this issue.

@mbtamuli
Copy link

@mbtamuli mbtamuli commented Jan 7, 2020

I'm not able to work on this for now. If no one takes this up, I'll look at it again.

@mbtamuli mbtamuli removed their assignment Jan 7, 2020
@PrasadG193
Copy link
Member Author

@PrasadG193 PrasadG193 commented Feb 26, 2020

Fixed with #243

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
bug good first issue
Projects
None yet
Development

No branches or pull requests

3 participants