Permalink
Browse files

Bundle gemspec dependencies

  • Loading branch information...
1 parent 6049bd7 commit 63a5029c17dd2e050b2f12021919f4545eb993ce @infused committed Nov 12, 2010
Showing with 79 additions and 14 deletions.
  1. +1 −5 Gemfile
  2. +71 −4 Gemfile.lock
  3. +1 −0 Rakefile
  4. 0 bin/dbf
  5. +4 −3 dbf.gemspec
  6. +1 −1 lib/dbf.rb
  7. +1 −1 lib/dbf/memo.rb
View
@@ -1,6 +1,2 @@
+gemspec
source :rubygems
-
-gem 'activesupport', '3.0.0'
-gem 'i18n', '0.4.1'
-gem 'rspec', '2.1.0'
-gem 'fastercsv', '1.5.3'
View
@@ -1,10 +1,68 @@
+PATH
+ remote: .
+ specs:
+ dbf (1.3.0)
+ activesupport (= 3.0.1)
+ fastercsv (= 1.5.3)
+
GEM
remote: http://rubygems.org/
specs:
- activesupport (3.0.0)
+ Saikuro (1.1.0)
+ activesupport (3.0.1)
+ arrayfields (4.7.4)
+ chronic (0.2.3)
+ hoe (>= 1.2.1)
+ churn (0.0.12)
+ chronic (~> 0.2.3)
+ hirb
+ json_pure
+ main
+ ruby_parser (~> 2.0.4)
+ sexp_processor (~> 3.0.3)
+ colored (1.2)
diff-lcs (1.1.2)
fastercsv (1.5.3)
- i18n (0.4.1)
+ fattr (2.2.0)
+ flay (1.4.1)
+ ruby_parser (~> 2.0)
+ sexp_processor (~> 3.0)
+ flog (2.5.0)
+ ruby_parser (~> 2.0)
+ sexp_processor (~> 3.0)
+ hirb (0.3.5)
+ hoe (2.6.2)
+ rake (>= 0.8.7)
+ rubyforge (>= 2.0.4)
+ json_pure (1.4.6)
+ main (4.3.0)
+ arrayfields (>= 4.7.4)
+ fattr (>= 2.1.0)
+ metric_fu (2.0.0)
+ Saikuro (>= 1.1.0)
+ activesupport (>= 2.0.0)
+ chronic (~> 0.2.3)
+ churn (>= 0.0.7)
+ flay (>= 1.2.1)
+ flog (>= 2.2.0)
+ rails_best_practices (>= 0.3.16)
+ rcov (>= 0.8.3.3)
+ reek (>= 1.2.6)
+ roodi (>= 2.1.0)
+ progressbar (0.9.0)
+ rails_best_practices (0.5.0)
+ activesupport
+ colored (~> 1.2)
+ progressbar (~> 0.9.0)
+ ruby_parser (~> 2.0.4)
+ rake (0.8.7)
+ rcov (0.9.9)
+ reek (1.2.8)
+ ruby2ruby (~> 1.2)
+ ruby_parser (~> 2.0)
+ sexp_processor (~> 3.0)
+ roodi (2.1.0)
+ ruby_parser
rspec (2.1.0)
rspec-core (~> 2.1.0)
rspec-expectations (~> 2.1.0)
@@ -13,12 +71,21 @@ GEM
rspec-expectations (2.1.0)
diff-lcs (~> 1.1.2)
rspec-mocks (2.1.0)
+ ruby2ruby (1.2.5)
+ ruby_parser (~> 2.0)
+ sexp_processor (~> 3.0)
+ ruby_parser (2.0.5)
+ sexp_processor (~> 3.0)
+ rubyforge (2.0.4)
+ json_pure (>= 1.1.7)
+ sexp_processor (3.0.5)
PLATFORMS
ruby
DEPENDENCIES
- activesupport (= 3.0.0)
+ activesupport (= 3.0.1)
+ dbf!
fastercsv (= 1.5.3)
- i18n (= 0.4.1)
+ metric_fu (= 2.0.0)
rspec (= 2.1.0)
View
@@ -1,6 +1,7 @@
# encoding: utf-8
require 'rubygems'
+require 'metric_fu'
require 'rspec/core/rake_task'
RSpec::Core::RakeTask.new :spec do |t|
View
0 bin/dbf 100644 → 100755
No changes.
View
@@ -22,8 +22,9 @@ Gem::Specification.new do |s|
s.require_paths = ['lib']
s.required_rubygems_version = '>= 1.3.0'
- s.add_dependency('activesupport', ['= 3.0.0'])
- s.add_dependency('fastercsv', ['= 1.5.3'])
- s.add_development_dependency('rspec', ['>= 1.3.0'])
+ s.add_dependency 'activesupport', '3.0.1'
+ s.add_dependency 'fastercsv', '1.5.3'
+ s.add_development_dependency 'rspec', '2.1.0'
+ s.add_development_dependency 'metric_fu', '2.0.0'
end
View
@@ -1,5 +1,5 @@
require 'date'
-gem 'activesupport', '=3.0.0'
+gem 'activesupport'
require 'active_support/core_ext/object'
require 'active_support/core_ext/date/conversions'
require 'active_support/core_ext/time/conversions'
View
@@ -7,7 +7,7 @@ class Memo
attr_reader :data
def initialize(data, format, version)
- @data, @format, @version = data, format, version
+ @data, @format, @version = data, format.to_sym, version
get_block_size
end

0 comments on commit 63a5029

Please sign in to comment.