nesty edited this page Oct 11, 2017 · 12 revisions

Nester Develop

Nester Develop is an extension for The Visual Studio Code IDE. A number of other tools and libraries are provided along with the extension to develop dotnet core applications on the nest.yt PaaS.

Nester Develop

Pre-requisites

  • Visual Studio Code. Install vscode IDE along with the C# and the Nester Develop extensions.
  • Dotnet Core. The dotnet core framework version should match the deployed version.
  • Docker. Install docker to run nest services locally.
  • Git version 2.10 or higher. The Devkit is designed to keep all work in a single folder. The SSH keys are maintained in the local folder for checking out the remote repository. Removing the folder removes all work related to the development. This allows for a clean development environment that makes the least impact on the system. This Git version provides support for local SSH keys.

Supported Platforms

  • Windows (64-bit only)
  • macOS 10.12 (Sierra) and newer
  • Ubuntu 14.04+ (and distros based on it)
  • Debian 8.7+
  • Red Hat Enterprise Linux (RHEL) / CentOS / Oracle Linux 7.3+
  • Fedora 23 / 24 / 25
  • OpenSUSE 42.2+
You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.
Press h to open a hovercard with more details.