Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bitmap export: Palette misses one color #39

Closed
dertseha opened this issue Sep 9, 2018 · 0 comments
Closed

Bitmap export: Palette misses one color #39

dertseha opened this issue Sep 9, 2018 · 0 comments
Labels
bug
Milestone

Comments

@dertseha
Copy link
Member

@dertseha dertseha commented Sep 9, 2018

An exported bitmap opened in Gimp for instance misses one color in the colormap (to be precise: the first one). When such an image is re-saved with gimp, the palette is changed and importing it via the editor does again a colormapping - instead of the intended 1:1 palette index copy.

As a result, no animated pixels can be drawn.

It will be better to not export an image with transparency, but rather use the palette as-is. Meaning, areas that the engine treats as "transparent" are painted with color index 0.
While this removes the "feature" to have immediately reusable PNG files (with proper transparency), the use case of modifying them in a graphics program is far more common.

@dertseha dertseha added the bug label Sep 9, 2018
@dertseha dertseha added this to the v1.1.3 milestone Sep 9, 2018
@dertseha dertseha closed this Sep 9, 2018
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.