New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Installing the plugin from WP CLI the mlp_languages is not created #281

Closed
davidetaddei opened this Issue Aug 24, 2017 · 3 comments

Comments

3 participants
@davidetaddei

davidetaddei commented Aug 24, 2017

Version Information

  • PHP: 7.1.8 (Docker image php:7.1.8-apache)
  • WordPress: 4.8

Steps to Reproduce

  1. Launch installation with

docker exec -itu www-data CONTAINER_NAME php wp-cli.phar plugin install https://downloads.wordpress.org/plugin/multilingual-press.2.8.1.zip --force --activate-network

  1. There is no mlp_languages table in the database.

What I Expected

I expected to find language list in the dropdown under MultilingualPress tab (/wp-admin/network/site-settings.php?id=1&extra=mlp-site-settings).

What Happened Instead

There is not language list in the dropdown under MultilingualPress tab (/wp-admin/network/site-settings.php?id=1&extra=mlp-site-settings). Only the Choose Language label is available.

@tfrommen

This comment has been minimized.

Show comment
Hide comment
@tfrommen

tfrommen Aug 25, 2017

Contributor

duplicate #230


Hi,

this is a known issue, see #230, and it has already been fixed for the upcoming major release.

We will discuss fixing this for 2.x as well...

Contributor

tfrommen commented Aug 25, 2017

duplicate #230


Hi,

this is a known issue, see #230, and it has already been fixed for the upcoming major release.

We will discuss fixing this for 2.x as well...

@davidetaddei

This comment has been minimized.

Show comment
Hide comment
@davidetaddei

davidetaddei Aug 25, 2017

Thank you Thorsten, I read the #230. I agree it would be great to make the plugin WP CLI compliant even in this version at least for the basic function (installation, activation, etc..)

davidetaddei commented Aug 25, 2017

Thank you Thorsten, I read the #230. I agree it would be great to make the plugin WP CLI compliant even in this version at least for the basic function (installation, activation, etc..)

Dinamiko added a commit that referenced this issue Aug 29, 2017

@tfrommen tfrommen added this to the v2.9.0 milestone Aug 29, 2017

Dinamiko added a commit that referenced this issue Aug 29, 2017

@tfrommen

This comment has been minimized.

Show comment
Hide comment
@tfrommen

tfrommen Sep 14, 2017

Contributor

Fixed in 3919ebd.

Contributor

tfrommen commented Sep 14, 2017

Fixed in 3919ebd.

@tfrommen tfrommen closed this Sep 14, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment