BackWPup - WordPress Backup Plugin
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
assets
inc
languages
vendor
.htaccess
backwpup.php
changelog.txt
license.txt
readme.md
uninstall.php

readme.md

BackWPup Pro - WordPress Backup Plugin

Schedule complete automatic backups of your WordPress installation. Decide which content will be stored (Dropbox, S3…). This is the free version

Description

The backup plugin BackWPup Pro can be used to save your complete installation including /wp-content/ and push them to an external Backup Service, like Dropbox, S3, FTP and many more, see list below. With a single backup .zip file you are able to easily restore an installation.

BackWPup Free is the number 1 backup-plugin for WordPress with nearly 1.000.000 downloads and in the top 20 of all WordPress Plugins (checked on rankwp.com)

  • Database Backup (needs mysqli)
  • WordPress XML Export
  • Generate a file with installed plugins
  • Optimize Database
  • Check and repair Database
  • File backup
  • Backups in zip, tar, tar.gz format (needs gz, ZipArchive)
  • Store backup to directory
  • Store backup to FTP server (needs ftp)
  • Store backup to Dropbox (needs curl)
  • Store backup to S3 services (needs curl)
  • Store backup to Microsoft Azure (Blob) (needs PHP 5.3.2, curl)
  • Store backup to RackSpaceCloud (needs PHP 5.3.2, curl)
  • Store backup to SugarSync (needs curl)
  • Store backup to Amazon Glacier (needs PHP 5.3.2, curl)
  • Store backup to Google Drive (needs curl)
  • Send logs and backups by email
  • Multi-site support only as network admin

Remember: The most expensive backup is the one you never did! And please test your backups!

Made by Inpsyde · We love WordPress

Available languages

  • english (standard)
  • french / français (fr_FR)
  • german / deutsch (de_DE)
  • russian / русский (ru_RU)
  • simplified chinese (zh_CN)

Requirements

  • WordPress 3.8 and PHP 5.2.6 required!
  • To use the Plugin with full functionality PHP 5.3.3 with mysqli, FTP,gz, bz2, ZipArchive and curl is needed.
  • Plugin functions that don't work because of your server settings, will not be displayed in admin area.

Screenshots

  1. Working job and jobs overview
  2. Job creation/edit
  3. Displaying logs
  4. Manage backup archives
  5. Dashboard