Skip to content

ins1gn1a/VulnServer-Linux

master
Switch branches/tags
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
 
 
 
 
 
 

VulnServer

CI Status GitHub pull-requests GitHub contributors GitHub issues GitHub stars GitHub license

This program should not be run on any production systems or networks as it is purposely vulnerable. I will not be held accountable for any usage of this program and you run this at your own risk.

Prerequisites

apt install gcc gcc-multilib
wget https://raw.githubusercontent.com/ins1gn1a/VulnServer-Linux/master/vuln.c

Compile

gcc vuln.c -o vuln -fno-stack-protector -z execstack -mpreferred-stack-boundary=2 -m32

References

Inspiration from Stephen Bradshaw's vulnserver!

About

Intentionally vulnerable Linux application for buffer overflow and RCE development practice

Topics

Resources

License

Stars

Watchers

Forks

Packages

No packages published

Languages