Permalink
Browse files

Correctly allow all supporting versions of PostgreSQL to use secure s…

…tring escaping.

git-svn-id: http://svn.inspircd.org/repository/trunk/inspircd@6443 e03df62e-2008-0410-955e-edbf42e46eb7
  • Loading branch information...
peavey
peavey committed Jan 27, 2007
1 parent 3ae4c96 commit 49ce55f7a38fc9b6beb972442c828429456797a0
Showing with 1 addition and 1 deletion.
  1. +1 −1 src/modules/extra/m_pgsql.cpp
@@ -27,7 +27,7 @@
#include "m_sqlv2.h"
/* $ModDesc: PostgreSQL Service Provider module for all other m_sql* modules, uses v2 of the SQL API */
/* $CompileFlags: -Iexec("pg_config --includedir") eval("my $s = `pg_config --version`;$s =~ /^.*?(\d+)\.(\d+)\.(\d+).*?$/;my $v = hex(sprintf("0x%02x%02x%02x", $1, $2, $3));print "-DPGSQL_HAS_ESCAPECONN" if($v >= 0x080104);") */
/* $CompileFlags: -Iexec("pg_config --includedir") eval("my $s = `pg_config --version`;$s =~ /^.*?(\d+)\.(\d+)\.(\d+).*?$/;my $v = hex(sprintf("0x%02x%02x%02x", $1, $2, $3));print "-DPGSQL_HAS_ESCAPECONN" if(($v >= 0x080104) || ($v >= 0x07030F && $v < 0x070400) || ($v >= 0x07040D && $v < 0x080000) || ($v >= 0x080008 && $v < 0x080100));") */
/* $LinkerFlags: -Lexec("pg_config --libdir") -lpq */
/* $ModDep: m_sqlv2.h */

0 comments on commit 49ce55f

Please sign in to comment.