Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 53 lines (34 sloc) 1.777 kb
5247be0 Peter Powell Add source installation guides.
SaberUK authored
1 # InspIRCd Wiki » Module Manager
2
3 InspIRCd ships with a tool called `./modulemanager`. This tool allows you to easily install modules
4 that are not included with the default distribution, such as third party modules and modules which
5 have been backported from later versions. The module manager tool is located in the root directory
6 of your InspIRCd installation.
7
8 ## Syntax
9
10 ```
11 Use: ./modulemanager <action> <args>
12 Action is one of the following
13 install install new modules
14 upgrade upgrade installed modules
15 list lists available modules
16
17 For installing a package, specify its name or name=version to force the installation of a specific
18 version.
19 ```
20
21 ## Common errors
22
23 ### Can't locate LWP/Simple.pm in @INC
24
25 Your system is missing the libwww-perl package. You should install it from your appropriate package
26 manager.
27
28 * **CentOS, Fedora** &mdash; yum install perl-libwww-perl
29 * **Debian, Ubuntu** &mdash; apt-get install libwww-perl
30
31
32 ### Could not retrieve https://raw.github.com/inspircd/inspircd-extras/master/modules.lst
33
34 There is a problem with your internet connection or your system is missing LWP SSL support and
35 module manager is not detecting this properly.
36
37 The latter is a known issue, see [issue #154](https://github.com/inspircd/inspircd/issues/154) for
38 more details.
39
40 ## Installing modules without the module manager
41
42 If for some reason you are unable to use the module manager you can download and install modules
43 manually using the following steps:
44
45 1. Download the module you wish to install from the [inspircd-extras](https://github.com/inspircd/inspircd-extras)
46 repository on GitHub.
47
48 2. Move it to the src/modules directory.
49
50 3. **1.2 only** Run ./configure -modupdate.
51
52 4. Run "make install" to build and install the module.
Something went wrong with that request. Please try again.