Skip to content
Permalink
Browse files

Change .goreleaser.yml to support go module build

  • Loading branch information...
s1061123 committed Jun 14, 2019
1 parent d134ac8 commit 33f077ce1b9c8757c0570df4ff37a1a4364cf1ae
Showing with 7 additions and 2 deletions.
  1. +5 −0 .goreleaser.yml
  2. +1 −1 build
  3. +1 −1 test.sh
@@ -1,5 +1,10 @@
# This is an example goreleaser.yaml file with some sane defaults.
# Make sure to check the documentation at http://goreleaser.com
env:
- GO111MODULE=on
before:
hooks:
- go mod download
builds:
-
env:
2 build
@@ -23,7 +23,7 @@ LDFLAGS="-X main.version=${VERSION:-master} -X main.commit=${COMMIT} -X main.dat
export CGO_ENABLED=0

# this if... will be removed when gomodules goes default
if [ $GO111MODULE == "off" ]; then
if [ "$GO111MODULE" == "off" ]; then
echo "Building plugin without go module"
echo "Warning: this will be deprecated in near future so please use go modules!"

@@ -2,7 +2,7 @@
set -e

# this if... will be removed when gomodules goes default
if [ $GO111MODULE == "off" ]; then
if [ "$GO111MODULE" == "off" ]; then
echo "Warning: this will be deprecated in near future so please use go modules!"

ORG_PATH="github.com/intel"

0 comments on commit 33f077c

Please sign in to comment.
You can’t perform that action at this time.