invalid byte sequence in US-ASCII #237

Closed
reesew opened this Issue Aug 7, 2015 · 7 comments

Comments

Projects
None yet
4 participants
@reesew

reesew commented Aug 7, 2015

I followed the commands in the typical workflow, and get the following error/trace

/usr/local/bundle/gems/erubis-2.7.0/lib/erubis/converter.rb:132:in `scan': invalid byte sequence in US-ASCII (ArgumentError)
        from /usr/local/bundle/gems/erubis-2.7.0/lib/erubis/converter.rb:132:in `convert_input'
        from /usr/local/bundle/gems/erubis-2.7.0/lib/erubis/converter.rb:36:in `convert'
        from /usr/local/bundle/gems/erubis-2.7.0/lib/erubis/engine.rb:30:in `initialize'
        from /usr/local/bundle/gems/prmd-0.7.4/lib/prmd/template.rb:45:in `new'
        from /usr/local/bundle/gems/prmd-0.7.4/lib/prmd/template.rb:45:in `load'
        from /usr/local/bundle/gems/prmd-0.7.4/lib/prmd/template.rb:54:in `load_template'
        from /usr/local/bundle/gems/prmd-0.7.4/lib/prmd/template.rb:64:in `render'
        from /usr/local/bundle/gems/prmd-0.7.4/lib/prmd/templates/schemata.md.erb:2:in `result'
        from /usr/local/bundle/gems/erubis-2.7.0/lib/erubis/evaluator.rb:65:in `eval'
        from /usr/local/bundle/gems/erubis-2.7.0/lib/erubis/evaluator.rb:65:in `result'
        from /usr/local/bundle/gems/prmd-0.7.4/lib/prmd/templates/schema.erb:7:in `block in result'
        from /usr/local/bundle/gems/prmd-0.7.4/lib/prmd/templates/schema.erb:4:in `each'
        from /usr/local/bundle/gems/prmd-0.7.4/lib/prmd/templates/schema.erb:4:in `map'
        from /usr/local/bundle/gems/prmd-0.7.4/lib/prmd/templates/schema.erb:4:in `result'
        from /usr/local/bundle/gems/erubis-2.7.0/lib/erubis/evaluator.rb:65:in `eval'
        from /usr/local/bundle/gems/erubis-2.7.0/lib/erubis/evaluator.rb:65:in `result'
        from /usr/local/bundle/gems/prmd-0.7.4/lib/prmd/core/renderer.rb:49:in `render'
        from /usr/local/bundle/gems/prmd-0.7.4/lib/prmd/commands/render.rb:34:in `render'
        from /usr/local/bundle/gems/prmd-0.7.4/lib/prmd/cli/doc.rb:65:in `execute'
        from /usr/local/bundle/gems/prmd-0.7.4/lib/prmd/cli/base.rb:141:in `run'
        from /usr/local/bundle/gems/prmd-0.7.4/lib/prmd/cli.rb:93:in `run'
        from /usr/local/bundle/gems/prmd-0.7.4/bin/prmd:6:in `<top (required)>'
        from /usr/local/bundle/bin/prmd:23:in `load'
        from /usr/local/bundle/bin/prmd:23:in `<main>'
@reesew

This comment has been minimized.

Show comment
Hide comment
@reesew

reesew Aug 8, 2015

nevermind, this was a docker problem, solved by this article

reesew commented Aug 8, 2015

nevermind, this was a docker problem, solved by this article

@reesew reesew closed this Aug 8, 2015

@geemus

This comment has been minimized.

Show comment
Hide comment
@geemus

geemus Aug 12, 2015

Member

Thanks for the update, I've also run into that issue and it was frustrating
to figure out. Glad you are back in working order.

On Fri, Aug 7, 2015 at 7:03 PM, reesew notifications@github.com wrote:

Closed #237 #237.


Reply to this email directly or view it on GitHub
#237 (comment).

Member

geemus commented Aug 12, 2015

Thanks for the update, I've also run into that issue and it was frustrating
to figure out. Glad you are back in working order.

On Fri, Aug 7, 2015 at 7:03 PM, reesew notifications@github.com wrote:

Closed #237 #237.


Reply to this email directly or view it on GitHub
#237 (comment).

@parikhparth23

This comment has been minimized.

Show comment
Hide comment

same error

@geemus

This comment has been minimized.

Show comment
Hide comment
@geemus

geemus Mar 28, 2016

Member

@parikhparth23 are you in a docker environment? Could you share some additional details to help us narrow it down? Thanks!

Member

geemus commented Mar 28, 2016

@parikhparth23 are you in a docker environment? Could you share some additional details to help us narrow it down? Thanks!

@parikhparth23

This comment has been minimized.

Show comment
Hide comment
@parikhparth23

parikhparth23 Mar 28, 2016

@geemus i followed the steps by reesew...and added the environment variable in Jenkins and it is working fine now!
Thank you for your reply!

@geemus i followed the steps by reesew...and added the environment variable in Jenkins and it is working fine now!
Thank you for your reply!

@geemus

This comment has been minimized.

Show comment
Hide comment
@geemus

geemus Mar 28, 2016

Member

Thanks for the update, glad to hear it!

Member

geemus commented Mar 28, 2016

Thanks for the update, glad to hear it!

@110y

This comment has been minimized.

Show comment
Hide comment
@110y

110y Jun 8, 2017

I also faced this error in the docker container, and fixed by below:

RUN locale-gen en_US.UTF-8
RUN localedef -f UTF-8 -i en_US en_US.UTF-8

ENV LANG en_US.UTF-8
ENV LANGUAGE en_US:en
ENV LC_ALL en_US.UTF-8

110y commented Jun 8, 2017

I also faced this error in the docker container, and fixed by below:

RUN locale-gen en_US.UTF-8
RUN localedef -f UTF-8 -i en_US en_US.UTF-8

ENV LANG en_US.UTF-8
ENV LANGUAGE en_US:en
ENV LC_ALL en_US.UTF-8
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment