Skip to content
This repository
Browse code

Note Vend::Swish change, and upgrade ramifications of removed extra/ …

…modules.
  • Loading branch information...
commit 444bed9bf05bcd043ba95fa33e0f3aa435b9b63a 1 parent 5b0441b
Jon Jensen jonjensen authored

Showing 2 changed files with 16 additions and 1 deletion. Show diff stats Hide diff stats

  1. +11 0 UPGRADE
  2. +5 1 WHATSNEW-5.5
11 UPGRADE
@@ -94,6 +94,17 @@ This issue does not affect earlier versions of PostgreSQL.
94 94
95 95 KNOWN ISSUES UPGRADING FROM 5.5.2
96 96
  97 +Several old versions of CPAN modules were distributed in the extra/ directory
  98 +but have been removed:
  99 +
  100 + Business::UPS - part of Bundle::InterchangeKitchenSink
  101 + File::Spec - now distributed with Perl itself
  102 + Tie::ShadowHash - part of Bundle::Interchange
  103 + URI::URL - part of Bundle::Interchange
  104 +
  105 +If you find Interchange won't start up, check to make sure you have all the
  106 +necessary Perl modules.
  107 +
97 108 The syntax of the custom SQL function for counters has changed. At the time
98 109 of the feature's introduction on 2007-11-17, the syntax was e.g.:
99 110
6 WHATSNEW-5.5
@@ -8,7 +8,7 @@
8 8 See UPGRADE document for a list of incompatible changes.
9 9
10 10
11   -Interchange 5.5.3 not yet released.
  11 +Interchange 5.5.3 released on 2008-05-17.
12 12
13 13 Core
14 14 ----
@@ -105,6 +105,10 @@ Core
105 105
106 106 And whatever the custom_counter function returns will be used by Interchange.
107 107
  108 +* Removed original Vend::Swish, and renamed prior Vend::Swish2 to Vend::Swish.
  109 + This module uses the Swish Perl API instead of calling a Swish subprocess
  110 + and dealing with shell escapes.
  111 +
108 112 Filters
109 113 -------
110 114

0 comments on commit 444bed9

Please sign in to comment.
Something went wrong with that request. Please try again.