Browse files

* Change UPGRADE document to be more clear, based on feedback from

  brian on IRC.
  • Loading branch information...
1 parent c774605 commit c4b50732706a4b0a48165b629fe0dbc2d9a4c4b2 @perusionmike perusionmike committed Oct 22, 2002
Showing with 36 additions and 17 deletions.
  1. +36 −17 UPGRADE
View
53 UPGRADE
@@ -9,16 +9,41 @@ be compatible with 4.7.
Full information on upgrades is available in the document icupgrade(8)
(in the distribution in pod/icupgrade.pod).
-To upgrade from another 4.x version, it is recommended that you:
+To upgrade from 4.8, it is recommended that you:
1. Make a tar backup of your Interchange software directory, i.e.
- tar xzvf ~/ic_backup.tar.gz /usr/lib/interchange
+ tar czvf ~/ic_backup.tar.gz /usr/lib/interchange
- 2. Install over the top of it by specifying the same installation
- directory during the installation.
+ 2. Unpack the new version of the software and change
+ to that directory.
- 3. If you have this line in interchange.cfg:
+ tar xzf interchange-5.x.tar.gz
+ cd interchange-5.x
+
+ 3. Install it in the same location as your current software:
+
+ ## Create the makefile
+ perl Makefile.PL prefix=/usr/lib/interchange
+
+ ## Make the software
+ make
+
+ ## Test -- if this fails, don't worry too much.
+ make test
+
+ ## Install the software
+ make install
+
+ 4. You don't need to run makecat again!!!
+
+ 5. Restart Interchange.
+
+That should be it. Test the catalog to make sure it works.
+
+IF YOU UPGRADED FROM 4.6.x
+
+If you have this line in interchange.cfg:
#include usertag/*
@@ -34,21 +59,15 @@ To upgrade from another 4.x version, it is recommended that you:
include usertag/my_tag
- 4. If you use CyberCash, you should replace these lines in catalog.cfg
+If you use CyberCash, you should replace these lines in catalog.cfg
- Variable CYBER_MODE mauthonly
- Variable CYBER_CONFIGFILE /path/to/your/merchant_conf
+ Variable CYBER_MODE mauthonly
+ Variable CYBER_CONFIGFILE /path/to/your/merchant_conf
- with
+ with
- Variable MV_PAYMENT_MODE cybercash
- Variable MV_PAYMENT_CONFIGFILE /path/to/your/merchant_conf
-
- 5. Restart Interchange.
-
-That should be it. Test the catalog to make sure it works.
-
-IF YOU UPGRADED FROM 4.6.x
+ Variable MV_PAYMENT_MODE cybercash
+ Variable MV_PAYMENT_CONFIGFILE /path/to/your/merchant_conf
There is one security change that can break constructs that ran under 4.6.x.

0 comments on commit c4b5073

Please sign in to comment.