Skip to content
Permalink
Browse files

feat: bump version of all crates to 1.0.0

  • Loading branch information
Ben Striegel authored and bstrie committed Feb 8, 2020
1 parent ed83801 commit 3f1a8de2a359c02c8d8edda88eacdd652d3992bd

Some generated files are not rendered by default. Learn more.

@@ -1,6 +1,6 @@
[package]
name = "ilp-cli"
version = "0.3.0"
version = "1.0.0"
authors = ["Ben Striegel <bstriegel@ripple.com>"]
description = "Interledger.rs Command-Line Interface"
license = "Apache-2.0"
@@ -1,6 +1,6 @@
[package]
name = "ilp-node"
version = "0.6.0"
version = "1.0.0"
authors = ["Evan Schwartz <evan@ripple.com>"]
description = "Interledger node (sender, connector, receiver bundle)"
license = "Apache-2.0"
@@ -32,7 +32,7 @@ required-features = ["redis"]


[dependencies]
interledger = { path = "../interledger", version = "^0.6.0", default-features = false, features = ["node"] }
interledger = { path = "../interledger", version = "1.0.0", default-features = false, features = ["node"] }

bytes = { version = "0.4.12", default-features = false }
bytes05 = { package = "bytes", version = "0.5", default-features = false }
@@ -1,26 +1,26 @@
[package]
name = "interledger-api"
version = "0.3.0"
version = "1.0.0"
authors = ["Evan Schwartz <evan@ripple.com>"]
description = "API for managing an Interledger node"
license = "Apache-2.0"
edition = "2018"
repository = "https://github.com/interledger-rs/interledger-rs"

[dependencies]
interledger-packet = { path = "../interledger-packet", version = "^0.4.0", default-features = false }
interledger-http = { path = "../interledger-http", version = "^0.4.0", default-features = false }
interledger-ildcp = { path = "../interledger-ildcp", version = "^0.4.0", default-features = false }
interledger-rates = { path = "../interledger-rates", version = "^0.4.0", default-features = false }
interledger-router = { path = "../interledger-router", version = "^0.4.0", default-features = false }
interledger-service = { path = "../interledger-service", version = "^0.4.0", default-features = false }
interledger-service-util = { path = "../interledger-service-util", version = "^0.4.0", default-features = false }
interledger-settlement = { path = "../interledger-settlement", version = "^0.3.0", default-features = false }
interledger-spsp = { path = "../interledger-spsp", version = "^0.4.0", default-features = false }
interledger-stream = { path = "../interledger-stream", version = "^0.4.0", default-features = false }
interledger-ccp = { path = "../interledger-ccp", version = "^0.3.0", default-features = false }
interledger-btp = { path = "../interledger-btp", version = "^0.4.0", default-features = false }
interledger-errors = { path = "../interledger-errors", version = "^0.1.0", default-features = false, features = ["warp_errors"] }
interledger-packet = { path = "../interledger-packet", version = "1.0.0", default-features = false }
interledger-http = { path = "../interledger-http", version = "1.0.0", default-features = false }
interledger-ildcp = { path = "../interledger-ildcp", version = "1.0.0", default-features = false }
interledger-rates = { path = "../interledger-rates", version = "1.0.0", default-features = false }
interledger-router = { path = "../interledger-router", version = "1.0.0", default-features = false }
interledger-service = { path = "../interledger-service", version = "1.0.0", default-features = false }
interledger-service-util = { path = "../interledger-service-util", version = "1.0.0", default-features = false }
interledger-settlement = { path = "../interledger-settlement", version = "1.0.0", default-features = false }
interledger-spsp = { path = "../interledger-spsp", version = "1.0.0", default-features = false }
interledger-stream = { path = "../interledger-stream", version = "1.0.0", default-features = false }
interledger-ccp = { path = "../interledger-ccp", version = "1.0.0", default-features = false }
interledger-btp = { path = "../interledger-btp", version = "1.0.0", default-features = false }
interledger-errors = { path = "../interledger-errors", version = "1.0.0", default-features = false, features = ["warp_errors"] }

bytes = { version = "0.5", default-features = false }
futures = { version = "0.3.1", default-features = false }
@@ -1,16 +1,16 @@
[package]
name = "interledger-btp"
version = "0.4.0"
version = "1.0.0"
authors = ["Evan Schwartz <evan@ripple.com>"]
description = "Bilateral Transfer Protocol (BTP) client and server services for Interledger.rs"
license = "Apache-2.0"
edition = "2018"
repository = "https://github.com/interledger-rs/interledger-rs"

[dependencies]
interledger-errors = { path = "../interledger-errors", version = "^0.1.0", default-features = false }
interledger-packet = { path = "../interledger-packet", version = "^0.4.0", default-features = false }
interledger-service = { path = "../interledger-service", version = "^0.4.0", default-features = false }
interledger-errors = { path = "../interledger-errors", version = "1.0.0", default-features = false }
interledger-packet = { path = "../interledger-packet", version = "1.0.0", default-features = false }
interledger-service = { path = "../interledger-service", version = "1.0.0", default-features = false }

bytes = { version = "0.4.12", default-features = false }
byteorder = { version = "1.3.2", default-features = false }
@@ -1,16 +1,16 @@
[package]
name = "interledger-ccp"
version = "0.3.0"
version = "1.0.0"
authors = ["Evan Schwartz <evan@ripple.com>"]
description = "Implementation of the Interledger Dynamic Configuration Protocol (ILDCP)"
license = "Apache-2.0"
edition = "2018"
repository = "https://github.com/interledger-rs/interledger-rs"

[dependencies]
interledger-errors = { path = "../interledger-errors", version = "^0.1.0", default-features = false }
interledger-packet = { path = "../interledger-packet", version = "^0.4.0", default-features = false }
interledger-service = { path = "../interledger-service", version = "^0.4.0", default-features = false }
interledger-errors = { path = "../interledger-errors", version = "1.0.0", default-features = false }
interledger-packet = { path = "../interledger-packet", version = "1.0.0", default-features = false }
interledger-service = { path = "../interledger-service", version = "1.0.0", default-features = false }

bytes = { version = "0.4.12", default-features = false }
byteorder = { version = "1.3.2", default-features = false }
@@ -1,13 +1,13 @@
[package]
name = "interledger-errors"
version = "0.1.0"
version = "1.0.0"
authors = ["Georgios Konstantopoulos <me@gakonst.com>"]
edition = "2018"

# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html

[dependencies]
interledger-packet = { path = "../interledger-packet", version = "^0.4.0", default-features = false }
interledger-packet = { path = "../interledger-packet", version = "1.0.0", default-features = false }

once_cell = { version = "1.3.1", default-features = false }
thiserror = { version = "1.0.10", default-features = false }
@@ -1,16 +1,16 @@
[package]
name = "interledger-http"
version = "0.4.0"
version = "1.0.0"
authors = ["Evan Schwartz <evan@ripple.com>"]
description = "HTTP client and server services for Interledger.rs"
license = "Apache-2.0"
edition = "2018"
repository = "https://github.com/interledger-rs/interledger-rs"

[dependencies]
interledger-errors = { path = "../interledger-errors", version = "^0.1.0", default-features = false }
interledger-packet = { path = "../interledger-packet", version = "^0.4.0", default-features = false }
interledger-service = { path = "../interledger-service", version = "^0.4.0", default-features = false }
interledger-errors = { path = "../interledger-errors", version = "1.0.0", default-features = false }
interledger-packet = { path = "../interledger-packet", version = "1.0.0", default-features = false }
interledger-service = { path = "../interledger-service", version = "1.0.0", default-features = false }

bytes = { version = "0.5", default-features = false }
futures = { version = "0.3", default-features = false }
@@ -1,15 +1,15 @@
[package]
name = "interledger-ildcp"
version = "0.4.0"
version = "1.0.0"
authors = ["Evan Schwartz <evan@ripple.com>"]
description = "Implementation of the Interledger Dynamic Configuration Protocol (ILDCP)"
license = "Apache-2.0"
edition = "2018"
repository = "https://github.com/interledger-rs/interledger-rs"

[dependencies]
interledger-packet = { path = "../interledger-packet", version = "^0.4.0", default-features = false }
interledger-service = { path = "../interledger-service", version = "^0.4.0", default-features = false }
interledger-packet = { path = "../interledger-packet", version = "1.0.0", default-features = false }
interledger-service = { path = "../interledger-service", version = "1.0.0", default-features = false }

bytes = { version = "0.4.12", default-features = false }
byteorder = { version = "1.3.2", default-features = false }
@@ -1,6 +1,6 @@
[package]
name = "interledger-packet"
version = "0.4.0"
version = "1.0.0"
authors = ["Evan Schwartz <evan@ripple.com>"]
description = "Interledger packet serialization/deserialization"
license = "Apache-2.0"
@@ -1,18 +1,19 @@
[package]
name = "interledger-rates"
version = "0.4.0"
version = "1.0.0"
authors = ["Evan Schwartz <evan@ripple.com>"]
description = "Exchange rate utilities"
license = "Apache-2.0"
edition = "2018"
repository = "https://github.com/interledger-rs/interledger-rs"

[dependencies]
interledger-errors = { path = "../interledger-errors", version = "1.0.0" }

async-trait = "0.1.22"
futures = { version = "0.3.1", default-features = false }
interledger-errors = { path = "../interledger-errors", version = "^0.1.0" }
log = { version = "0.4.8", default-features = false }
once_cell = "1.3.1"
once_cell = { version = "1.3.1", default-features = false }
reqwest = { version = "0.10.0", default-features = false, features = ["default-tls", "json"] }
secrecy = { version = "0.6", default-features = false, features = ["alloc", "serde"] }
serde = { version = "1.0.101", default-features = false, features = ["derive"]}
@@ -1,15 +1,15 @@
[package]
name = "interledger-router"
version = "0.4.0"
version = "1.0.0"
authors = ["Evan Schwartz <evan@ripple.com>"]
description = "Router for Interledger requests"
license = "Apache-2.0"
edition = "2018"
repository = "https://github.com/interledger-rs/interledger-rs"

[dependencies]
interledger-packet = { path = "../interledger-packet", version = "^0.4.0", default-features = false }
interledger-service = { path = "../interledger-service", version = "^0.4.0", default-features = false }
interledger-packet = { path = "../interledger-packet", version = "1.0.0", default-features = false }
interledger-service = { path = "../interledger-service", version = "1.0.0", default-features = false }

log = { version = "0.4.8", default-features = false }
parking_lot = { version = "0.10.0", default-features = false }
@@ -19,4 +19,4 @@ async-trait = { version = "0.1.22", default-features = false }
[dev-dependencies]
once_cell = { version = "1.3.1", default-features = false }
tokio = { version = "0.2.6", default-features = false, features = ["rt-core", "macros"]}
interledger-errors = { path = "../interledger-errors", version = "^0.1.0", default-features = false }
interledger-errors = { path = "../interledger-errors", version = "1.0.0", default-features = false }

0 comments on commit 3f1a8de

Please sign in to comment.
You can’t perform that action at this time.