Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Rake::Pipeline::Middleware needs a Project #16

Merged
merged 1 commit into from

3 participants

@listrophy

The argument to use Rake::Pipeline::Middleware is expected to be a Rake::Pipeline::Project, not a String.

@listrophy listrophy Rake::Pipeline::Middleware needs a Project
The argument to `use Rake::Pipeline::Middleware` is expected to be a Rake::Pipeline::Project, not a String.
9da40a0
@pjmorse

Is this why when I accidentally bundle update and get the most-recent rake pipeline, my project blows up?

@pjmorse

Why yes, yes it is. Thanks, @listrophy!

@devinus devinus merged commit ba7a97f into interline:master
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Dec 15, 2012
  1. @listrophy

    Rake::Pipeline::Middleware needs a Project

    listrophy authored
    The argument to `use Rake::Pipeline::Middleware` is expected to be a Rake::Pipeline::Project, not a String.
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 1 deletion.
  1. +1 −1  config.ru
View
2  config.ru
@@ -1,6 +1,6 @@
require 'rake-pipeline'
require 'rake-pipeline/middleware'
-use Rake::Pipeline::Middleware, 'Assetfile'
+use Rake::Pipeline::Middleware, Rake::Pipeline::Project.new('Assetfile')
# require 'rack/streaming_proxy'
# use Rack::StreamingProxy do |request|
Something went wrong with that request. Please try again.