Skip to content
This repository

multi_json gem version requirement #185

flah00 opened this Issue · 2 comments

2 participants

Philip Champon Daniel Doubrovkine (dB.) @dblockdotorg
Philip Champon
flah00 commented

Someone more familiar with the multi_json code base should update the gemspec, to include a minimum version for multi_json. It appears that MultiJson#dump is relatively new (4/12) and the lack of a version causes issues for people with older versions. I know 1.3.6 has #dump, but I'm uncertain what the minimum version is... I could submit a PR for version 1.3.6, but that seems inaccurate and therefore unwanted.

Daniel Doubrovkine (dB.) @dblockdotorg
dblock commented

I would track down when `dump was introduced, make sure Grape tests fail with the version before and then add a >= in gemspec. I bet it's 1.3.5, but I wouldn't bet on it :)

Caleb Crane simulacre referenced this issue from a commit in simulacre/grape
Caleb Crane simulacre refs: #185 gemspec requires multi_json >= 1.3.2
MultiJson.dump was introduced in version 1.3.2.

An alternative approach would be to use MultiJson.encode if
MultiJson.dump is not available.
Daniel Doubrovkine (dB.) @dblockdotorg

Locked at >= 1.3.2 in simulacre@885e74c

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.