Permalink
Browse files

Use RUBY_ENGINE constant instead of RUBY_VERSION env var

  • Loading branch information...
1 parent 4be991a commit 926234768fbe850336a18316ddf3dc734a082555 @josh josh committed Apr 14, 2011
Showing with 2 additions and 4 deletions.
  1. +2 −4 multi_json.gemspec
View
@@ -1,8 +1,6 @@
# -*- encoding: utf-8 -*-
require File.expand_path("../lib/multi_json/version", __FILE__)
-ENV['RUBY_VERSION'] ||= ''
-
Gem::Specification.new do |s|
s.name = "multi_json"
s.version = MultiJson::VERSION
@@ -29,11 +27,11 @@ Gem::Specification.new do |s|
s.add_development_dependency("json", "~> 1.4")
s.add_development_dependency("json_pure", "~> 1.4")
- unless ENV['RUBY_VERSION'].match(/^rbx-/)
+ unless RUBY_ENGINE == "rbx"
s.add_development_dependency("rcov", "~> 0.9")
end
- unless ENV['RUBY_VERSION'].match(/^jruby-/)
+ unless RUBY_ENGINE == "jruby"
s.add_development_dependency("yajl-ruby", "~> 0.7")
end
end

0 comments on commit 9262347

Please sign in to comment.