Skip to content
This repository
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 28 lines (26 sloc) 1.253 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
# coding: utf-8
lib = File.expand_path('../lib', __FILE__)
$LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
require 'oauth2/version'

Gem::Specification.new do |spec|
  spec.add_dependency 'faraday', ['>= 0.8', '< 0.10']
  spec.add_dependency 'jwt', '~> 0.1.8'
  spec.add_dependency 'multi_json', '~> 1.3'
  spec.add_dependency 'multi_xml', '~> 0.5'
  spec.add_dependency 'rack', '~> 1.2'
  spec.add_development_dependency 'bundler', '~> 1.0'
  spec.authors = ['Michael Bleigh', 'Erik Michaels-Ober']
  spec.description = %q(A Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth spec.)
  spec.email = ['michael@intridea.com', 'sferik@gmail.com']
  spec.files = %w(.document CONTRIBUTING.md LICENSE.md README.md Rakefile oauth2.gemspec)
  spec.files += Dir.glob('lib/**/*.rb')
  spec.files += Dir.glob('spec/**/*')
  spec.homepage = 'http://github.com/intridea/oauth2'
  spec.licenses = %w(MIT)
  spec.name = 'oauth2'
  spec.require_paths = %w(lib)
  spec.required_rubygems_version = '>= 1.3.5'
  spec.summary = %q(A Ruby wrapper for the OAuth 2.0 protocol.)
  spec.test_files = Dir.glob('spec/**/*')
  spec.version = OAuth2::Version
end
Something went wrong with that request. Please try again.