Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Gem dependency refactor

  • Loading branch information...
commit 854e5f816d1f40d0fdaf583eb170aeddb4fc8476 1 parent 1e06d87
Erik Michaels-Ober sferik authored
0  .gemtest
View
No changes.
4 .yardopts
View
@@ -0,0 +1,4 @@
+--markup markdown
+--markup-provider maruku
+-
+LICENSE
10 Gemfile
View
@@ -1,9 +1,3 @@
-source "http://rubygems.org"
+source 'http://rubygems.org'
-gem 'oa-core', :path => File.expand_path('../../oa-core/', __FILE__)
-gem 'ruby-openid-apps-discovery'
-# Will automatically pull in this gem and all its
-# dependencies specified in the gemspec
-gem 'oa-openid', :path => File.expand_path("..", __FILE__)
-
-eval File.read(File.join(File.dirname(__FILE__), '../development_dependencies.rb'))
+gemspec
14 Rakefile
View
@@ -1,14 +1,6 @@
-require 'rubygems'
require 'bundler'
-Bundler.setup
-require 'rake'
-
-require 'mg'
-MG.new('oa-openid.gemspec')
-
+Bundler::GemHelper.install_tasks
require 'rspec/core/rake_task'
-RSpec::Core::RakeTask.new(:spec) do |s|
- s.rspec_opts = "--format=#{ENV['RSPEC_FORMAT'] || 'nested'} --colour"
-end
-
+RSpec::Core::RakeTask.new(:spec)
task :default => :spec
+task :test => :spec
34 oa-openid.gemspec
View
@@ -1,19 +1,25 @@
-version = File.open(File.dirname(__FILE__) + '/../VERSION', 'r').read.strip
+# -*- encoding: utf-8 -*-
+require File.expand_path('../../omniauth/lib/omniauth/version', __FILE__)
Gem::Specification.new do |gem|
- gem.name = "oa-openid"
- gem.version = version
- gem.summary = %Q{OpenID strategies for OmniAuth.}
- gem.description = %Q{OpenID strategies for OmniAuth.}
- gem.email = "michael@intridea.com"
- gem.homepage = "http://github.com/intridea/omniauth"
- gem.authors = ["Michael Bleigh"]
-
- gem.files = Dir.glob("{lib}/**/*") + %w(README.rdoc LICENSE)
-
- gem.add_dependency 'oa-core', version
+ gem.add_dependency 'oa-core', Omniauth::VERSION.dup
gem.add_dependency 'rack-openid', '~> 1.2.0'
gem.add_dependency 'ruby-openid-apps-discovery'
-
- eval File.read(File.join(File.dirname(__FILE__), '../development_dependencies.rb'))
+ gem.add_development_dependency 'rack-test', '~> 0.5'
+ gem.add_development_dependency 'rake', '~> 0.8'
+ gem.add_development_dependency 'rspec', '~> 2.5'
+ gem.add_development_dependency 'webmock', '~> 1.6'
+ gem.add_development_dependency 'yard', '~> 0.6'
+ gem.name = 'oa-openid'
+ gem.version = Omniauth::VERSION.dup
+ gem.summary = %q{OpenID strategies for OmniAuth.}
+ gem.description = %q{OpenID strategies for OmniAuth.}
+ gem.email = ['michael@intridea.com', 'sferik@gmail.com']
+ gem.homepage = 'http://github.com/intridea/omniauth'
+ gem.authors = ['Michael Bleigh', 'Erik Michaels-Ober']
+ gem.executables = `git ls-files -- bin/*`.split("\n").map{|f| File.basename(f)}
+ gem.files = `git ls-files`.split("\n")
+ gem.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ gem.require_paths = ['lib']
+ gem.required_rubygems_version = Gem::Requirement.new('>= 1.3.6') if gem.respond_to? :required_rubygems_version=
end
Please sign in to comment.
Something went wrong with that request. Please try again.