You can clone with
HTTPS or Subversion.
Hi, I have this error:
/usr/lib/ruby/gems/1.8/gems/activesupport-3.0.4/lib/active_support/dependencies.rb:239:in `require': no such file to load -- oa-oauth (LoadError)
while I do have oa-auth gem installed and it's in default gems path. I have RVM installed but system settings used in this case.
You need to require omniauth/oauth instead. Though this may be something that I fix in the future.
thx for response. In this case I get 'undefined method `use' for main:Object (NoMethodError)'
@fenec you have to do config.middleware.use or something like that.
@mbleigh I had the same issue, with request omniauth/oauth I now have:
no such file to load -- omniauth/password (MissingSourceFile)
Add same-name files for each gem to allow for non-bundled use without…
… custom require. Closes #193
Check the version of omniauth in your bundle, (bundle show omniauth). If it is not explicitly specified in your gemfile you might end up with a 0.0.1 version, which causes the require password error.
I recently ran into jimmysoho's error as well. My app was using Omniauth fine for months until I installed RVM. Specifying the omniauth version as ">=0.2.6" fixes the issue for me. Removing that version specification and running bundle update reverts the version to 0.0.1.
Is this an Omniauth issue or an RVM one?
I wish I knew.
Thanks for posting this everyone, I resolved the same error based on the responses. It seems to be one of the only threads available addressing this issue.
Ran into the same problem when running bundle update without a version supplied for OmniAuth in the Gemfile.
It's likely due to the particular mix of dependencies in your app. For me, the latest Capybara requires Nokogiri v1.5+, which conflicts with OmniAuth's ~> 1.4.2, so Bundler appears to have worked its way back to an old version of OmniAuth that didn't conflict with Capybara's dependency.