Skip to content
This repository

no such file to load -- oa-oauth (LoadError) #193

Closed
fenec opened this Issue February 25, 2011 · 8 comments

7 participants

Fenec Michael Bleigh jimmysoho Martin Wawrusch eric-hu walteryu Kevin Rohrbaugh
Fenec

Hi, I have this error:

/usr/lib/ruby/gems/1.8/gems/activesupport-3.0.4/lib/active_support/dependencies.rb:239:in `require': no such file to load -- oa-oauth (LoadError)

while I do have oa-auth gem installed and it's in default gems path. I have RVM installed but system settings used in this case.
plz help

Michael Bleigh
Owner

You need to require omniauth/oauth instead. Though this may be something that I fix in the future.

Fenec
fenec commented March 01, 2011

Michael,
thx for response. In this case I get 'undefined method `use' for main:Object (NoMethodError)'

jimmysoho

@fenec you have to do config.middleware.use or something like that.

@mbleigh I had the same issue, with request omniauth/oauth I now have:

  no such file to load -- omniauth/password (MissingSourceFile)
Martin Wawrusch

@jimmysoho
Check the version of omniauth in your bundle, (bundle show omniauth). If it is not explicitly specified in your gemfile you might end up with a 0.0.1 version, which causes the require password error.

eric-hu

@mwawrusch
I recently ran into jimmysoho's error as well. My app was using Omniauth fine for months until I installed RVM. Specifying the omniauth version as ">=0.2.6" fixes the issue for me. Removing that version specification and running bundle update reverts the version to 0.0.1.

Is this an Omniauth issue or an RVM one?

Martin Wawrusch

@eric-hu
I wish I knew.

walteryu

Thanks for posting this everyone, I resolved the same error based on the responses. It seems to be one of the only threads available addressing this issue.

Kevin Rohrbaugh

Ran into the same problem when running bundle update without a version supplied for OmniAuth in the Gemfile.

It's likely due to the particular mix of dependencies in your app. For me, the latest Capybara requires Nokogiri v1.5+, which conflicts with OmniAuth's ~> 1.4.2, so Bundler appears to have worked its way back to an old version of OmniAuth that didn't conflict with Capybara's dependency.

This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.