Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Failed to precompile LibPQ with julia 1.2.0 #144

Closed
nicegeeker opened this issue Nov 8, 2019 · 5 comments
Closed

Failed to precompile LibPQ with julia 1.2.0 #144

nicegeeker opened this issue Nov 8, 2019 · 5 comments

Comments

@nicegeeker
Copy link

@nicegeeker nicegeeker commented Nov 8, 2019

ERROR: LoadError: InitError: ArgumentError: Unknown time zone "Asia/Shanghai"
Stacktrace:
[1] (::getfield(TimeZones, Symbol("##3#4")){SubString{String}})() at /Users/sat/.julia/packages/TimeZones/A5RcB/src/types/timezone.jl:54
[2] get!(::getfield(TimeZones, Symbol("##3#4")){SubString{String}}, ::Dict{String,Tuple{Dates.TimeZone,TimeZones.Class}}, ::String) at ./dict.jl:452
[3] Dates.TimeZone(::SubString{String}, ::TimeZones.Class) at ./dict.jl:443
[4] localzone() at /Users/sat/.julia/packages/TimeZones/A5RcB/src/local.jl:29
[5] Type at /Users/sat/.julia/packages/Memento/UgJr2/src/formatters.jl:35 [inlined]
[6] #config!#71(::String, ::Dict{AbstractString,Int64}, ::Bool, ::Bool, ::Bool, ::Bool, ::typeof(Memento.config!), ::Memento.Logger, ::String) at /Users/sat/.julia/packages/Memento/UgJr2/src/config.jl:39
[7] config! at /Users/sat/.julia/packages/Memento/UgJr2/src/config.jl:36 [inlined]
[8] #config!#70 at /Users/sat/.julia/packages/Memento/UgJr2/src/config.jl:28 [inlined]
[9] config! at /Users/sat/.julia/packages/Memento/UgJr2/src/config.jl:28 [inlined]
[10] #config!#69 at /Users/sat/.julia/packages/Memento/UgJr2/src/config.jl:25 [inlined]
[11] config! at /Users/sat/.julia/packages/Memento/UgJr2/src/config.jl:25 [inlined]
[12] init() at /Users/sat/.julia/packages/Memento/UgJr2/src/Memento.jl:62
[13] _include_from_serialized(::String, ::Array{Any,1}) at ./loading.jl:685
[14] _require_from_serialized(::String) at ./loading.jl:736
[15] _require(::Base.PkgId) at ./loading.jl:1023
[16] require(::Base.PkgId) at ./loading.jl:911
[17] require(::Module, ::Symbol) at ./loading.jl:906
[18] include at ./boot.jl:328 [inlined]
[19] include_relative(::Module, ::String) at ./loading.jl:1094
[20] include(::Module, ::String) at ./Base.jl:31
[21] top-level scope at none:2
[22] eval at ./boot.jl:330 [inlined]
[23] eval(::Expr) at ./client.jl:432
[24] top-level scope at ./none:3
during initialization of module Memento
in expression starting at /Users/sat/.julia/packages/LibPQ/WrMcC/src/LibPQ.jl:18

@iamed2

This comment has been minimized.

Copy link
Member

@iamed2 iamed2 commented Nov 8, 2019

Please try rebuilding TimeZones.jl; if that doesn't solve it please file an issue in TimeZones.jl since the issue occurs due to a call to TimeZones.localzone()

@nicegeeker

This comment has been minimized.

Copy link
Author

@nicegeeker nicegeeker commented Nov 10, 2019

I rebuild "TimeZone", but there is still another error.

ERROR: LoadError: could not open file /Users/sat/.julia/packages/LibPQ/WrMcC/deps/deps.jl
Stacktrace:
[1] include at ./boot.jl:328 [inlined]
[2] include_relative(::Module, ::String) at ./loading.jl:1094
[3] include at ./Base.jl:31 [inlined]
[4] include(::String) at /Users/sat/.julia/packages/LibPQ/WrMcC/src/LibPQ.jl:44
[5] top-level scope at /Users/sat/.julia/packages/LibPQ/WrMcC/src/LibPQ.jl:47
[6] include at ./boot.jl:328 [inlined]
[7] include_relative(::Module, ::String) at ./loading.jl:1094
[8] include(::Module, ::String) at ./Base.jl:31
[9] top-level scope at none:2
[10] eval at ./boot.jl:330 [inlined]
[11] eval(::Expr) at ./client.jl:432
[12] top-level scope at ./none:3
in expression starting at /Users/sat/.julia/packages/LibPQ/WrMcC/src/LibPQ.jl:47
Failed to precompile LibPQ [194296ae-ab2e-5f79-8cd4-7183a0a5a0d1] to /Users/sat/.julia/compiled/v1.2/LibPQ/LeQQU.ji.

Stacktrace:
[1] error(::String) at ./error.jl:33
[2] compilecache(::Base.PkgId, ::String) at ./loading.jl:1253
[3] _require(::Base.PkgId) at ./loading.jl:1013
[4] require(::Base.PkgId) at ./loading.jl:911
[5] require(::Module, ::Symbol) at ./loading.jl:906
[6] top-level scope at In[1]:4

@iamed2

This comment has been minimized.

Copy link
Member

@iamed2 iamed2 commented Nov 12, 2019

Now try rebuilding LibPQ

@iamed2 iamed2 closed this Dec 2, 2019
@Nosferican

This comment has been minimized.

Copy link

@Nosferican Nosferican commented Jan 18, 2020

Getting the same issue with

TimeZones v0.10.4
LibPQ v1.0.6

LibPQ will fail to precompile,

ERROR: LoadError: InitError: ArgumentError: Unhandled TZ environment variable format: "America/New_York"
Stacktrace:
 [1] parse_tz_format(::String) at /home/coder/.julia/packages/TimeZones/zNfhV/src/local.jl:170
 [2] localzone() at /home/coder/.julia/packages/TimeZones/zNfhV/src/local.jl:43
 [3] DefaultFormatter at /home/coder/.julia/packages/Memento/UgJr2/src/formatters.jl:35 [inlined]
 [4] #config!#71(::String, ::Dict{AbstractString,Int64}, ::Bool, ::Bool, ::Bool, ::Bool, ::typeof(Memento.config!), ::Memento.Logger, ::String) at /home/coder/.julia/packages/Memento/UgJr2/src/config.jl:39
 [5] config! at /home/coder/.julia/packages/Memento/UgJr2/src/config.jl:36 [inlined]
 [6] #config!#70 at /home/coder/.julia/packages/Memento/UgJr2/src/config.jl:28 [inlined]
 [7] config! at /home/coder/.julia/packages/Memento/UgJr2/src/config.jl:28 [inlined]
 [8] #config!#69 at /home/coder/.julia/packages/Memento/UgJr2/src/config.jl:25 [inlined]
 [9] config! at /home/coder/.julia/packages/Memento/UgJr2/src/config.jl:25 [inlined]
 [10] __init__() at /home/coder/.julia/packages/Memento/UgJr2/src/Memento.jl:62
 [11] _include_from_serialized(::String, ::Array{Any,1}) at ./loading.jl:692
 [12] _require_search_from_serialized(::Base.PkgId, ::String) at ./loading.jl:776
 [13] _require(::Base.PkgId) at ./loading.jl:1001
 [14] require(::Base.PkgId) at ./loading.jl:922
 [15] require(::Module, ::Symbol) at ./loading.jl:917
 [16] include at ./boot.jl:328 [inlined]
 [17] include_relative(::Module, ::String) at ./loading.jl:1105
 [18] include(::Module, ::String) at ./Base.jl:31
 [19] top-level scope at none:2
 [20] eval at ./boot.jl:330 [inlined]
 [21] eval(::Expr) at ./client.jl:425
 [22] top-level scope at ./none:3
during initialization of module Memento
in expression starting at /home/coder/.julia/packages/LibPQ/PeS3p/src/LibPQ.jl:18
ERROR: Failed to precompile LibPQ [194296ae-ab2e-5f79-8cd4-7183a0a5a0d1] to /home/coder/.julia/compiled/v1.3/LibPQ/LeQQU_Y9O0m.ji.
Stacktrace:
 [1] error(::String) at ./error.jl:33
 [2] compilecache(::Base.PkgId, ::String) at ./loading.jl:1283
 [3] _require(::Base.PkgId) at ./loading.jl:1024
 [4] require(::Base.PkgId) at ./loading.jl:922
 [5] require(::Module, ::Symbol) at ./loading.jl:917

Fix would be JuliaTime/TimeZones.jl#210

@iamed2

This comment has been minimized.

Copy link
Member

@iamed2 iamed2 commented Jan 21, 2020

I'll get this dealt with in TimeZones

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants
You can’t perform that action at this time.