New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Remove bokeh matplotlib compatibility #1239

Merged
merged 1 commit into from Apr 4, 2017

Conversation

Projects
None yet
2 participants
@philippjfr
Member

philippjfr commented Apr 3, 2017

As suggested in #1218 this removes the BokehMPLWrapper plot class and support for Distribution, Bivariate, and TimeSeries Elements. I was initially hesitant to remove this entirely in 1.7 but with the amount of warnings these currently generate and other restrictions on these plot types, I think just removing them is the correct thing to do. Hopefully we can readd Distribution and Bivariate support in 2.0 as part of the statistical elements module (#1200).

@philippjfr philippjfr added this to the v1.7.0 milestone Apr 3, 2017

@jlstevens

This comment has been minimized.

Member

jlstevens commented Apr 4, 2017

Looks good.

I share your worries about backwards compatibility but BokehMPLWrapper is not meant to be - you can tell from the name that (if nothing else!), you are linking two dependencies that ought to be separate.

As we are removing functionality, I do think we definitely ought to get the corresponding statistical elements into 2.0. This is something we should mention in the CHANGELOG to try and re-assure anyone using these things that this functionality will be restored in a better way soon.

Merging.

@jlstevens jlstevens merged commit 946199d into master Apr 4, 2017

4 checks passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
continuous-integration/travis-ci/push The Travis CI build passed
Details
coverage/coveralls Coverage increased (+0.2%) to 78.343%
Details
s3-reference-data-cache Tests passing no test data changes required.
Details

@jbednar jbednar deleted the deprecate_bokeh_mpl branch Apr 4, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment