Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

refactor(angular): switch to @ionic/angular-toolkit #487

Merged
merged 1 commit into from Oct 5, 2018

Conversation

@dwieeb
Copy link
Member

dwieeb commented Oct 5, 2018

Upgrade steps:

npm uninstall @ionic/ng-toolkit
npm uninstall @ionic/schematics-angular
npm install --save-dev @ionic/angular-toolkit

Then, change all references of ng-toolkit/schematics-angular in angular.json to angular-toolkit. See "Files changed" above for exact changes.

@dwieeb dwieeb merged commit bdfee8d into master Oct 5, 2018
4 checks passed
4 checks passed
ci/circleci: build Your tests passed on CircleCI!
Details
ci/circleci: test_angular Your tests passed on CircleCI!
Details
ci/circleci: test_ionic1 Your tests passed on CircleCI!
Details
ci/circleci: test_ionic_angular Your tests passed on CircleCI!
Details
@dwieeb dwieeb deleted the angular-toolkit branch Oct 5, 2018
@25121294

This comment has been minimized.

Copy link

25121294 commented Oct 5, 2018

Hey there, I don't know what's up but after your commit I can't start the aws starter.

@dwieeb

This comment has been minimized.

Copy link
Member Author

dwieeb commented Oct 6, 2018

@25121294 This commit shouldn't change the aws starter. Create a new issue so I can take a look.

@rapropos

This comment has been minimized.

Copy link

rapropos commented Oct 10, 2018

This causes peer dependency mismatches for me on a new blank project. @ionic/angular-toolkit@1.0.0 wants 0.9.0-beta.3 of @angular-devkit/* but ~0.7.2 is declared in package.json. Might it be prudent to wait on this switchover until you are going to move entirely to @angular/cli 7?

@dwieeb

This comment has been minimized.

Copy link
Member Author

dwieeb commented Oct 10, 2018

@rapropos Yeah... I was noticing that as well. I think the peer deps here are just too strict. They work with ~0.7.2.

@squistbe

This comment has been minimized.

Copy link

squistbe commented Mar 6, 2019

I have tried npm install --save-dev @ionic/angular-toolkit and I am getting an error Not Found: @ionic/angular-toolkit@latest.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.