Upgrades super old Xcode projects to Xcode 8
Switch branches/tags
Nothing to show
Clone or download
Latest commit c89b62e Nov 22, 2017
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
fastlane
lib/fastlane/plugin
spec
.gitignore
.rspec
.rubocop.yml
.travis.yml
Gemfile
LICENSE
README.md
Rakefile
circle.yml
fastlane-plugin-upgrade_super_old_xcode_project.gemspec

README.md

upgrade_super_old_xcode_project plugin

fastlane Plugin Badge License Gem

This fastlane plugin can upgrade super old Xcode project files to a format current tooling can work with (pre Xcode 8 to Xcode 8), by adding the missing attributes to the project config.

It is 99% based on previous code that was part of fastlane-plugin-update_project_codesigning (deprecated!) (which got merged into the core action automatic_code_signing.rb - when the relevant code unfortunately got removed).

Getting Started

This project is a fastlane plugin. To get started with fastlane-plugin-upgrade_super_old_xcode_project, add it to your project by running:

fastlane add_plugin upgrade_super_old_xcode_project

Example

Check out the example Fastfile to see how to use this plugin. Try it by cloning the repo, running fastlane install_plugins and bundle exec fastlane test.

Run tests for this plugin

To run both the tests, and code style validation, run

rake

To automatically fix many of the styling issues, use

rubocop -a

Issues and Feedback

For any other issues and feedback about this plugin, please submit it to this repository.

Troubleshooting

If you have trouble using plugins, check out the Plugins Troubleshooting guide.

Using fastlane Plugins

For more information about how the fastlane plugin system works, check out the Plugins documentation.

About fastlane

fastlane is the easiest way to automate beta deployments and releases for your iOS and Android apps. To learn more, check out fastlane.tools.