Skip to content
Permalink
Browse files

[driver] Warn about use of unsupported software

It is no longer possible to fix any bugs that might be discovered in
gPXE, and sanbootconf is unlikely to be hacked to work around any such
bugs.  Users should upgrade to iPXE instead, since iPXE is actively
maintained.

Signed-off-by: Michael Brown <mbrown@fensystems.co.uk>
  • Loading branch information
mcb30 committed Feb 24, 2011
1 parent 76f7a9e commit 86e01ad80176cf0e2f2deeb61ace7673741bf192
Showing with 6 additions and 0 deletions.
  1. +6 −0 src/driver/acpi.c
@@ -86,6 +86,12 @@ NTSTATUS find_acpi_table ( PCHAR signature,
"\"%.6s\" OEM table ID \"%.8s\"\n", signature,
( BASEMEM_START + offset ), table->oem_id,
table->oem_table_id );
/* Warn about use of unsupported software */
if ( strcmp ( table->oem_table_id, "gPXE" ) == 0 ) {
DbgPrint ( "*** WARNING: gPXE is no longer supported; "
"please upgrade to iPXE (http://ipxe.org) "
"***\n" );
}
/* Create copy of table */
*table_copy = ExAllocatePoolWithTag ( NonPagedPool,
table->length,

0 comments on commit 86e01ad

Please sign in to comment.
You can’t perform that action at this time.