Skip to content

Version comparison error ( '2.1.11' < '2.1.4' ==> True) #1511

Closed
haridas opened this Issue Mar 21, 2012 · 4 comments

2 participants

@haridas
haridas commented Mar 21, 2012

Hi,

The version comparison inside the "/usr/local/lib/python2.7/dist-packages/IPython/zmq/init.py" file has a bug related to the string comparison. Because string comparison gives wrong result even though we had met the minimum required version of zmq.

for eg; minimum required zmq is '2.1.4'.

My system already had zmq-2.1.11, but while doing string comparison it raise an error and says :-

"ImportError: IPython.zmq requires pyzmq >= 2.1.4, but you have 2.1.11".

Regards,
Haridas N.

@takluyver
IPython member

What version of IPython do you have? This should have been fixed some time ago - see issue #870.

@haridas
haridas commented Mar 21, 2012

Hi,

Thanks for showing the old thread.

I'm using ipython-0.11.

root@debian:~# ipython
Python 2.7.2+ (default, Jan 20 2012, 17:51:10)
IPython 0.11 -- An enhanced Interactive Python.

But the #870 was actually ipython-0.10.

Thank you,
Haridas N.

IPython 0.11 -- An enhanced Interactive Python.

@takluyver
IPython member

OK, I'm closing this, then, since it's fixed in 0.12.

@takluyver takluyver closed this Mar 21, 2012
@haridas
haridas commented Mar 21, 2012

Thank you.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.