Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

can't activate IPython parallel magics #209

Closed
jmrohwer opened this Issue · 4 comments

3 participants

@jmrohwer

IPython version: 0.11.dev
When trying to activate the IPython parallel magics from within an IPython session, I'm getting the following traceback (running from a fresh git install).

In [1]: from IPython.kernel import client

/usr/local/src/ipython/IPython/kernel/client.py:48: DeprecationWarning:
twisted.internet.error.PotentialZombieWarning was deprecated in Twisted
10.0.0: There is no longer any potential for zombie process.
from twisted.internet.error import PotentialZombieWarning
2010-11-22 21:47:33+0200 [-] Log opened.

In [2]: mec=client.MultiEngineClient()
2010-11-22 21:47:46+0200 [-] Connecting [0]
2010-11-22 21:47:46+0200 [Negotiation,client] Connected:
/home/jr/.ipython/cluster_default/security/ipcontroller-mec.furl

In [3]: mec.activate()

AttributeError Traceback (most recent call last)
/home/jr/ in ()
----> 1 mec.activate()

/usr/local/src/ipython/IPython/kernel/multiengineclient.py in activate(self)
273 print "The IPython parallel magics (%result, %px,
%autopx) only work within IPython."
274 else:
--> 275 pmagic = ip.get_component('parallel_magic')
276 if pmagic is not None:
277 pmagic.active_multiengine_client = self

AttributeError: 'TerminalInteractiveShell' object has no attribute
'get_component'

@minrk
Owner

Lots of the Twisted-based parallel code is broken in 0.11, and will not be fixed. It is to be deprecated, and possibly removed before 0.11 release, in favor of the new ZeroMQ based parallel code, currently found in my newparallel branch:
http://github.com/minrk/ipython

If you want to use the Twisted parallel code, you should use 0.10.

Unfortunately, at this point there are several key things missing from the new parallel code, including the more sophisticated ipcluster scripts and the magics.

@ellisonbg
Owner

I am actually going to fix a few of these things...

@ellisonbg
Owner

I just pushed a fix to master. But autopx is still not working.

@ellisonbg
Owner

Everything should not be working with autopx.

@damianavila damianavila referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
@damianavila damianavila referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.